NAS SMB Shares work but adds too many folders?

Hi all

1st post and I need a bit of help I think.

I’m running the latest firmware as of today and can now access samba shares on my QNAP NAS.

Setting up is no problem, however when I select a single share to add it seems to add lot more than I want.


I have my files stored in seperate shares. Movies, TV, Photos, Music (plus other shares for non-media files)

When adding a share i’m entering the password and access is permitted no problem but when I select the Movies share to add to VIdeos on WDTV, it adds  the Movie share, plus all the other shares e.g Music, Photos, Documents!. It’s driving me mad!! haha.

I’m sure I must be missing something here? Any help much appreciated. :slight_smile:

Yeah, when you select your server, instead of choosing “Place Here” immediately, click the Share you want to add. and THEN do “Place Here.”

Only that share will be added, not the others.

Thanks for the quick response Tony. I’ll give that a go, but have a feeling that was what I’d been doing?.

The other 'alf has the telly now so a job for later. I’ll let you (everyone) know. Cheers

Hi there

I just purchased a WD TV Live Streaming and I have a QNAP T119+ and I can get NFS to work with the WD TV but  I cant get SMB/CIFS to work as I would like to have all my media come up in the Media Library.  The only thing showing in my media library is my local USB Drive but no NAS folders.

Please help!!!

@ TonyPh12345

Still no joy with adding shares, just doesn’t seem to want to accept a single share.

@ Super7

I had this problem too. Go to Microsoft networking in QNAP set up, untick and hit apply. Then tick and hit apply. Then WDTV should pick up QNAP.

I’ve had the best luck with making the QNAP the “Master Browser,” also configured in the QNAP’s Microsoft Networking configuration.

Thank you for both of your help.

I have made the adjustments remotely on my QNAAP and I will test it out on my WDTV LIve tonight when I get home.

I will let you know.

Well things have progressed a little, but still not as much as I’d hoped.

Following TonyPH12345s instructions I still cannot add single shares to the WDTV video folder, so I’m hiding all but Movies, TV, Music and Photos using the QNAP share manager. Each of these shares still shows up in the Video folder though.

I have managed to scrape the Movies and, apart from a few, the artwork is now displayed. Unfortunately TV refuses to scrape, but perhaps there’s another mystery setting somewhere that I haven’t found/been shown.

I guess that’s it for now until WD update the firmware…

I still cant get the Network Shares via SMB share so that I can aggregate all my content that includes USB drives and my QNAP Files.

I can access all my QNAP via NFS but that doesnt compile my Media Library the way it should.

I have like you said  went under Microsoft Networking and unticked and hit apply then selected it back and hit applied.

It still didnt work…I shouldnt have to restart the QNAP but that may be my final course of action.

I even thought it wouldnt allow me to share via SMB because I had enabled NFS but just in case I disabled NFS and enable SNMK via Microsoft  Networking .  I have both Workgroup names the same and still the WDTV Live doesnt see it.

Local Master Browser didnt work either.

This is getting a little frustrating…any help would be great or point me in a different direction.


Its starting to get very frustrating…

Super7:  Let’s try a different angle.

On your SMP, EJECT all your hard drives.   Unplug them.

Turn Content Info Collection to MANUAL under SETUP / SYSTEM

Reboot the SMP using the menu SETUP / SYSTEM / DEVICE RESTART.

Wait until “Compiling Media Library” is finished.

Change your CONTENT SOURCE to My Media Library.

Any improvement?