NAS not detected in my network


I am having problems detecting/setting up the MBL in my home network.

Steps tried so far:
-Connected to the router, tried MBL Software from the system - no luck
-Checked from router, confirmed the Byte send packets from the router but not receiving any packets from MBL
-No IP allocated from router’s DHCP table, tried rebooting both NAS/Router but no luck
-Connected directly to my PC, tried setting static ip over Ethernet adapter - no luck
-Tried reset couple of times as mentioned in the guide, MBL not rebooting/resetting with hard reset
-LED status remains green after its powered up

I have 2 new HDD’s which are 2TB WD and 2TB Seagate with no data in it.

Do I need to reinstall OS to these drives to get detected onto my network?
Does this NAS gets detected on network without any HDD’s installed on them?
Is there a way to access NAS directly over some IP/Subnet like setting up home router on LAN within same subnet?

Any input will be much appreciated:)


If you’re saying the hard drive inside the MBL is blank, then it has no operating system.