NAS not connecting on Yosemite

Apple today have released there new OS X Yosemite. I have upgraded to this and now my NAS drive will not connect. I have done some google and came accross this:

Q. I have a NAS drive but can no longer connect to it using the AFP protocol. What’s wrong?

A. AFP servers must support the Netatalk v2.2 protocol or later to work with Yosemite.

  • Apple has disabled AFP support for the Diffie-Hellman Key Exchange (DHX) Protocol (“DHCAST128”). DHCAST128 is often used by NAS boxes, mainly because it has fewer overheads. DHCAST128 is deprecated and replaced by Diffie-Hellman Key Exchange 2 (DHX2). The minimum size of the prime is increased to 512 bits to improve resistance to numerical methods of attack.
  • You should contact your NAS provider for an update to the NAS software.

Is WD going to bring out a firmware update for WD EX4 that is going to allow me to connect my nas back to my computer.


Interesting, I’ve just upgraded to OS X 10.10 as well.  I’ll test to the NAS w/ AFP but honestly I’m most excited about is SMB3 support.

AFP is inprocess of being depreciated anyways.

Have you enabled SMB3.0 support in your NAS to see if that might be both a solution and possible improvement?

My NAS drive use to come up under Shared on the side of finder and no longer is.

If there is a better way at connecting my NAS drive to my mac please inform me. How do I get SMB working?

Look under Windows Services in Settings/Network

Select SMB3 in the drop-down tab

I had a similar problem but in my case the NAS was visible immediately after updating to yosemite but then dissapeared! I think somehow the sharing options got messed up. In my case the fix was as follows…

Go to System preferences, select sharing, make sure File Sharing is ticked and on, then select the options on this pannel and ensure both SMB and AFP are ticked… (in my case only SMB was ticked). At this point the NAS drives reappeared on the shared section of the finder panel.

I’m no networking expert and just tend to muddle through these things but this seemed to work for me.