NAS Access problems (not authorized/password not accepted)

I have an access problem.

I have a WDMyCloudDL2100 and most PCs (2-4) run windows but an occasional mac is connected.

I have a small setup with an WindowsXP computer and 3 win7pro laptops, connected on the wlan router.

I have all files as public except one folder called “private”, which is accessed with the only password account there is - the “admin” login.

There are no other passwords planned as access is authorized with the network access, with the exception of that 1 folder that only the “NAS admin” can access.

Everything worked fine in the beginning and “fell apart” within a day or two on 2 separate but identical small networks.

I have 2 scenarios that I cannot figure out:
This goes from no problems all works fine - to the below scenarios right in the middle of a normal working day (no one changed anything) or the next day when you turn everything on in the morning.

1.) When I click on Network and then on the blue symbol for MYWDCloudDL2100, it says I’m not authorized to access (no name/password request option)

2.) It asks for a name & password, which I tip in and then comes a password request - which it also does not accept.

Since I’ve experienced this same behavior on 2 separate small networks, I was hoping someone else had this issue who could help.

There are really only 2 possible passwords in the system:

  1. router password
  2. admin on the NAS

It would also be ok if I had a setup where anyone who had access to the router - had access to the entire NAS (no private folder), if this may be what causing some of the problem.

The NAS was on the second network system not connected directly to the router but a hub, but it worked perfectly fine the first day.

All the unplugging tricks I’ve already tried ^^ sometimes it helps but not for long.

Please if anyone can help here it would be (after 2 weeks of trying) a great help :slight_smile:

Have you tried deleting the admin password by holding the reset switch on the back of the unit?

yes, but the problem/s keep showing up sooner or later on 2 separate (but similar) small networks - NAS is there, then its gone, a day later its back etc. Or its there but will accept neither the network nor the NAS password for access.

it’s a brand new DL2100 (mycloud)

I think I know what’s happened. You can’t be signed onto the server/NAS from the one OS with more than one user-name.

When your computer access the Public share, it’s authenticated to the server/NAS as guest. When you try sign-on with another user, you can’t. You computer’s OS is already authenticated itself.

For your own curiosity, temporally configure the Public share not to be publicly shared. See what happens.

A work-around to this is set the Public share as not-public and then in the list of users, give everyone read/write access to the share. This will mean that everyone who needs access to the NAS has to have a valid user-name and password and every authenticated user has full access to the Public share.

Try this and on the forum let us know what the results are.

ok thanks - I’ll try this on the weekend and let you know - this seems to answer a few questions already ^^