N900C - breaks internet connection


my problem is quite complex - the router after some time of operation loses connection to the internet. It looks like this :
1 Everything works .
2 On the laptop / tablet / whatever does not have access to the Internet.
3 Local network working ( media server ) .
4 VERY IMPORTANT - if any action was taken against the loss of access to the Internet , it is still running , such as Torrents are still downloading or Internet radio still playing , but anything new does not work ( you can not open web pages, start the NEW torrent or radio stations).
5 After rebooting the router , everything returns to normal, for about 20-40 minutes .
6 Internet stops working for both WLAN and LAN .
7 VERY IMPORTANT 2 - at a time when the internet was not working after logging in to the router settings page you can see on the desktop " connection status - connected to the Internet " and the " check the connection " can do ping any server up and running.

1 FasTrack Plus QoS disabled.
2 Enhanced WMM disabled.

What to do ? This is incredibly annoying !


Anyone? It’s driving me crazy, I have to reboot the router every 10 minutes!

It turns out that after the loss of Internet connection I can ping with the computer the IP address, eg “ping” works perfectly, but the “ping google.com” does not work at all. I tried to change the DNS settings of the router, but it does not help.

Is my MyNet N900C broken and I should return it?


What firmware are you running on the device?

Have you treid performing a factory reset?

FW 1.07.16.
I did factory reset, both through settings and through physical button on bottom of router. None of these didn’t help.

i dont wanna disapoint you, but i had three ,mynet 900 , all thre had the same issue.

torrent kills wifi , long files transfers kills wifi.

and seems to be that there is not going to be a new firmware.

i hope some day someone fix these issues.

stopped tried to fix them, there isnt much u can modify on the router neither.

i went back to my wrtg linksys.

mynet  900 had everything to be the best router ever, but simply dont work

Not very comforting.
What should I do? The complaint? Give back to the store? Anyone have experience how WD consider such a claim?

Hahaha, I downgraded FW to 1.6.28 and Internet works perfect. But… DLNA stopped working, every attempt to open any file ended with “filetype unknown”, and not only for files that were already on hd, but also for the ones I uploaded (including stupid txt file!). So, I have to decide do I need more the internet or stuff on hard drive…

Seriously WD? That is the worst pice of electronic equipment I have ever owned. Definitely do not buy nothing from WD never again, and I will be advised against to all my friends: (

You can contact wd support they will give you a rma replacement, in that aspect wd is awesone.
But there is something with the 900 series.
Didnt saw much issues with the 700 series, maybe replace the 900 with a small one

My hope is , wd make this router to work without issues

Any other response from the WD team than “what version of FW and was reset done”?
I still have this huge problem (restart every 30 min necessary) and I really hope for some advice …

Western Digital MyNet 900c may formally be declared a non-functional device, a product that should never have been released and for which the company is owing millions of dollars to customers they have defrauded with a non-functioning device. 

How may I formally declare this as a certainty? Because I returned my faulty device for a replacement which also exhibited the same exact failures. Internet connection broken every 10 minutes, immediately if any access to the internal hard drive is attempted. Following the instructions given by customer support did not fix the problem on either device.

I then humored myself, went out and bought a third item (to be immediately returned if not working) and found that it, too, suffered the same failures. The odds of 3 defective units out of 3 tries, for an otherwise functional product = too low to be plausible.

Summary = Western Digital is a hard drive company that fails in all other product line and should be investigated for massive consumer fraud.

For those of you who encounter the same problem as the OP, the solution should be disabling the DNS Proxy feature in the router settings. The setting comes enabled by default.

It can be found in  Advanced Settings / Host and LAN Settings

A few more details in my original post.