N900 routinely locking up every 36 - 48 hours

I have an N900 with the latest firmware.  Every few days the unit will stop service wireless and stop responding to the admin console.  It will still route wired traffic for a while then that eventually stops working.

This is very frustrating since I am now past my 30 day return window with Amazon.

If WD support is reading this you DID NOT FIX the 39 hour reboot issue, you just extended it to 48 hours.

Is anyone else having this issue and if so, have you been able to discover anything that will prevent it short of doing a daily reboot?

BTW, I’m not a noob or someone who needs to be coached through basic setup, I’m an IT Director with 30+ years experience.  There are some serious issue with the firmware that HAVE NOT been resolved.  I am very disappointed in WD.

Hey mjw930,

When you say “latest firmware”, do you mean 1.04.08 which is the latest?

If so, then I suppose that you updated to this version.  So after you updated, did you do a factory rest?  If not I would first try that.

Also, are you using the router in router or extender mode?

I have seen issues with the router dropping wireless connections, but I haven’t seen any issues with it dropping wired, so this could be a hardware issue (may not be, just saying that it’s a possibiltiy).  And just to let you know, even though WD does monitor this forum, if you need direct help from WD you’ll need to contact support.

Yes, it’s 1.04.08 and I did reset it after the upgrade but I suppose it’s worth a try to cycle it again.  I have already opened up a ticket.

I don’t believe it’s hardware, the wired ports maintain link and are still routed but the wireles quits and the admin interface stops responding.  That indicates the higher levels of the application running on the device had failed but the hardware and lower level functions still work.  I suspect the firewall and QOS have also stopped working at that point but it’s impossible to tell.  It acts like a memory leak considering the time element. Until it’s resolved or replaced I’ll be doing 48 hour reboots just so it doesn’t lock up when I need it as I work from home or I may simply reinstall my cradle point.

Ok, I’m a little confused by your problem then, because you said “It will still route wired traffic for a while then that eventually stops working.”, which is want lead me to say you might have a hardware issue, but now your saying “the wired ports maintain link”. 

Are you able to access the UI over LAN or are you just losing the ability to open the UI over a wireless connection?

The UI is unavailable from the wired interface.  Obviously it’s unavailable from wireless since that’s already stopped working.  The wired ports maintain link because that’s managed at the chip level, not a function of the Firmware.  What’s locking up is the OS, I doubt it’s a hardware issue, it acts like it just starts to,slow down until it finally consumes all the CPU or exhausts all it’s memory.  In other words it sounds like a memory leak.

I’ve reset it to factory default, reinstalled the latest firmware and reconfigured to my setup. I also changed the wireless settings to separate the 2.4 and 5ghz SSID’s and partition my devices to see if it is radio specific.  

WD support has replied but they didn’t give me much except to disable Fasttrack QoS which is unacceptable since part of why i purchased this device is to get the QoS capabilities for streaming video and IP telephony so if it continues to act up I’ll request an RMA and get a new box.

I am having same issue, router lights are all lit like it should be transmiting wireless signal but none of my devices see it. My wired devices can’t go online too. This is getting very anoying WD.

I’m also having issues printing via this router, my XP prints just fine and W7 prints junk.

Hope fix is on the way since I’m over my 30 days too.

I am having the exact same issues as you guys (drops wireless Internet connection after awhile despite SSID connected and showing; wired connection to my computer drops off at the same time). Seems to happen 1-2x per day. I am on the latest firmware. 

45 minutes ago I turned FastTrack+ off. We’ll see if this works. If not I will try a factory reset, then go onto more drastic measures (email WD). 

Well, happened two more times today despite turning off FasTrack Plus. Time to contact Western Union. It’s too bad because otherwise I really like the box; yes, I’m sure it’s not my modem - I was using a Buffalo router with DD-WRT firmware for over a year and it only needed to be reset once every few months. 

I have been experiencing the same issue.  Please  update this thread with any fix/findings.

Well, it is still acting up on me - 5 Internet disconnects yesterday and one when I woke up this morning. I’ve decided to do a factory-reset then set up the router from the Windows 7 router setup client instead of the WD router setup, and use only 1 SSID (2.4ghz only, turn off the dual-SSID setting for now that broadcasts 2.4ghz and 5ghz simultaneously). I’ve also disabled hybrid WPA/WPA2 security and gone with WPA2 only. I’ll report if this setup works or not.

This issue should have been resolved after updating to the latest firmware 1.04.11.


That version was not available when I posted the initial message.  I have upgraded and will see if that helps.  Thanks.

Well after 1.5 days, it seems ONE of my two modifications - going from two SSIDs to one (disabling 5ghz) and disabling dual WPA/WPA2 security - seems to have worked. I “only” had one very brief outage which lasted ~25 seconds then self-corrected without me even resetting the router. I will try upgrading to the new firmware to see how it does with two SSIDs though. 

Upgraded to latest firmware and noted 2 things.  First, I had to disable QoS, with it enabled accessing even basic websites was painfully slow.  Second, it locked up this morning and required a reboot.  I have not tried disabling 5ghz wifi as this is a requirement for me and one of the reasons I purchased this device.

IMHO this device is not ready for prime time, I will be replacing it soon.  Another $160 flushed down the toilet.

I flashed the new firmware two hours ago and went back to “normal” mode (dual-band, FastTrack QOS on) though I did leave security in WPA2 ONLY and not mixed-mode.

Worked fine for two hours, then lost IP. I was able to log into the router in my browser and renew the DHCP IP address. It’s now working again. However, to me having to renew the DHCP IP address manually for every few hours of use is just unacceptable. My dual-band Buffalo router running DD-WRT worked just fine with my current Motorola Surfboard Docsis 3.0 cable modem for months. 

Here is a comment I posted to this Amazon review, where reviewer “J Roman” is having the same problem we do. 

"I have the router, too, and have the same problem with losing IP connectivity every few hours of usage. It seemed to “heal” when I set it to single-band (2.4ghz-only) mode for 1.5 days, but this is a crappy solution since I prefer using the 5ghz band on capable devices. WD claimed that new firmware fixed this problem; for me and at least one other person on the WD Community forum, it did not.

Since not everyone seems to have this problem, I think it is due to one of two things. 1) Manufacturing defect with only some routers or 2) Firmware issue when dealing with some types of cable modems. Out of curiousity, what is your cable modem model? Mine is the  Motorola SURFboard Gateway SBG6580 DOCSIS 3.0 Wireless Cable Modem in bridge mode, which worked fine with my old router,  BUFFALO AirStation HighPower N600 Gigabit Dual Band Wireless Router - WZR-HP-AG300H, when using DD-WRT (not so well when using the default Buffalo firmware - IP signal dropped roughly every day)."

I have the same Motorola modem/router set in bridge mode with wireless disabled.  it has worked fine for over a year with a Cradlepoint router/switch behind it.  I made a couple of changes, I basically disabled IPv6 by setting it in local mode and turned QoS back on.  I also removed a thumb drive i had set up for NAS on one of the USB ports.  It seems to be working with QoS better but we will see if it stays up more than a day or two without freezing up.

OK so it may well be a modem-specific issue with this router. Let us know if disabling ipv6 has any effect :slight_smile:

This latest firmware didn’t fix the problem, but there are some changes (not improvements) to the router behavior.

Router wifi signal fails as it did before, but this time led light is out (used to stay lit), LAN is still working (used not to) and I can access my NAS, but can’t access the router.

WD you need to get your ish together and fix this problem or have a recall.


Dejan B.

I’m having the same issue running firmware 1.04.11 with both 2.4GHz and 5GHz wireless routinely failing after anywhere from a couple hours to maybe 6-8 hours tops (though not necessarily at the same time–often 2.4G goes down while 5G stays up, so possibly it’s interference from other networks causing issues).

I have just gone into the router configuration and disabled FastTrack Plus QoS (more like [Deleted]), and I’ve also disabled “Enhanced WMM” just to see if it helps. I’m running 12-16 PCs off this router, most of them wired, but the 2-4 laptops are all getting dropped. Rebooting every few hours is not acceptable.

sb8636 and mjw930 both stopped responding after their last post, so I don’t know if they fixed their problems (how?) or if they gave up and returned the N900. Any others out there find a suitable fix yet? I don’t need QoS or any other fancy stuff; I bought this router because of the dual-band 450+450Mb support along with eight GbE ports. If I have to go back to my old router just to maintain stability of WiFi, I will.