N900 Non-Central + 1.06.18 or 1.05.12 Firmware + Heavy EXT USB HDD = Lockup

N900 Non-Central + 1.06.18 or 1.05.12 Firmware + Heavy EXT USB HDD = Lockup as stated in subject line

Yes I know this firmware was pulled.  I have downgraded back to 1.05.12

This is for sure another bug in the firmware.  FTP use with same files was OK, when using mapped drive through win7 it locked up everytime.  I am still experiencing the same issues on the older firmware as well.  It happens when copying large files like HD movies 1.0GB - 4.7GB file size.  If i copy more than one at a time and not give it a break it locks up solid.

When locked up this happens…  No remote access through http, no wifi, no wired, no internet, no hdd, locked up solid.  Requires a hard boot by cycling power

For all of you heat haters out there this is not heat related.  I have qty 2 12VDC 40mm fans pushing air from underneath directly into bottom of router.  The entire router is room temp with zero hot spots.  This issue is related to the router itself, not heat.  USB 2.0 EXT HDD to wired lan to EXT USB in win7 machine.

The ironic issue is that the EXT HDD is a WD HDD Black 2.5" drive.

I am growing tired of this router and its teething issues.  I travel and depend on uptime for my house network, this router has less than 30 more days before it is tossed.  Never again.  Come on WD

1 Like

Have you tried resetting the router to factory default? Check page 70 of the manual. 


1 Like

You are killing me…  I have done every pratical, possible sequence to make firmware updates work.  Yes I have read the manual prior to posting hateful remarks about a router that i have dedicated over 20 hours to fix.  Stopping short of writing my own firmware, my only fix for western digitals firmware is to buy a linksys.

I have reset before and then updated

I have reset after updating

I have reset before and then after, after an update

I have tried firmware all the way back to 1.03 and came forward

I have even tried the firmware thay sent out and then recalled

1.05.12 is killing my internet speed

Now it is not even detected anymore.  Works in windows, not in router.  I have factory reset like 3 times to get it back, no dice.  Both USB ports are not working.  Neither my printer or my usb HDD are detected.

I have experienced the same thing. That being said, since downgrading to 1.04.11 I am happy.

It is true that the transfer rates to the attached HDD are half of what you get with 1.05.12, but at least the router works.