N900 - No 5g network! 2g works fine

Just got a new Mynet N900.  Latest frmware 1.07.16.

The 2g works flawlessly…  wired, wireless, SSID, port forwarding…

Issue:  I cannot see the wireless 5g.

5G is turned on, SSID broadcast is on.  My 2 HP desktops have a wired & wireless n card, and I can wirelessly connect to the 2.4 wireless.  I’ve tried manually confiring the network, but it seems the N900 is just broadcasting on 5G.

Neither my 2 HP Desktops, OR, my phone & tablet can see the 5G network.   i doubt it’s the Mynet because I had the same issue with new Netgear N900 that’s being returned.

This has got to be something simple!  But I have no idea what it could be.

My next step is to contct tech support.  I’m sure they’ll RMA it.  But I’m not convinced the router is defective since the Netgear N900 did the same thing.

Any suggestions?

  • There is no 'Ad/hoc setting on the network card’s properties, as someone had suggested for a diff n card.


A very unusual ocurrance…

When I turn off ‘SSI Broadcast’ on the 5hz network, WPA2-Personal security on the 2.4hz was turned off leaving it unsecured and open!!!  I had to reset the router to re-enable as it i could not re-enable security on the 2.4hz network either re-enableing SSI Broadcast on the 5hz, or, by changing the 2.4hz security.   I tested this twice more with the same results.   I spent about 2 hours testing this trying to find a solution.  And yes, I had the latest firmware.

I reset the router one final time, disconnected it, and it’s going back to Amazon not as a defective unit, but as a defected product hardware/firmware.  I’m back on my old reliable Syslink WRT54G.

Any suggstion that I should have contacted tech support is insulting!   Why would ANY router turn off one bands security by disableing SSI Braodcast on the other band?  OMG!  Fail!

It amazing me that people fresh out of college with maybe 1 to 2 years of work related experience are concidered experts in the field!  Whereas persons with years of experience are swept aside in favor of these young pups.   This is inexperience and poor programming - simple as that.

I also tested…

  • Zoom 5350 cable modem router.  No way man!  It’s a shared b/g/n network.  If you have 1 g device on the network, your N devices will be 54g max. 

  • LinkSysEA6500.  It would not let me access my new SB6141 Motorola cable modem for some reason.  To access it, one needs to bypass the router and connect it directly to the desktop!   Others also complained about that.  Also, it will not let you  access your port forwards from inside the network - going outside to your cable modem for testing.  Strange!   There are activity lights on the switch ports, but the ONLY light on the front is a slowly pulsating LinkSys logo on the top front!!!  WTH!

 I initially went with LinkSys, a top-of-the-line product.   Each one is not a deal breaker, but those 3 (plus a few more), is too much to put up with.   I’m re-concidering now.   

  • Netgear N900.  Router came with corrupted fIrmware!  I used Netgears oun process to flash the latest firmware, but am not convinced it’s fully working as the router takes longer than i think it should to boot up, and acts flacky.  Also, the Netgear does not even supply the utility needed to flash the firmware - your sent to 1 of 2 website, then need to figure out which of the software options you need on your own!  Not to mention there are NO activity lights on the switch ports or front. Is there activity on the wired ports?  We must have to guess!

Overall, I’m dissapointed in all 4 companies.  They all fail in my opinion.  I’ll be sending this message to each of them.

I would start with the largest and most respected… Linksys - aka Cisco.  Almost every business uses Cisco equipment.

Asus makes a pretty good product, I do not own one, but will be the next purchase. 

Linksys is now Belkin :wink:


WD Tech Support.

I did call WD and spoke with a tech.  It was apparent from the moment the tech answered from his voice I got the impression he was either very tired, or not at all wanting to be there!  His voice had was low,  mumble,  ‘I don’t want to be here’ attitude.  Wow, really!  That’s dissapointing.  There’s plenty of unemployed persons who would like the opportunity to earn some money.  It’s a good thing I’m not upper management in WD Customer service dept.

As i expected, they have not seen the issues I’ve been experienceing.  Turning ‘SSI Broadcast’ off for 5hz is not suppose to turn 2hz security off!  Hummmm.  

No resolution.  I may attempt to flash it back to the firmware on the CD to see if that resolves some of the issues.

No 5hz detected issue:

It is my less than expert opinion, that my ‘N’ devices simply cannot detect ‘N’ on the 5hz band!   They can connect on the 2.4hz band.  But in all my testing, I havn’t noticed if they connect  via ‘N’ on the 2.4 band.  I’ll retest this.

So, my next steps are…

  1. Retest to see if my ‘N’ devices can connect via ‘N’ on 2.4hz (is that even possible?).

  2. Flash the router back to the initial firmware and re-test the ‘SSI Broadcast/Security’ issue - to see if it stops.  If it stops, then it was introduces in a firmware update.  If it does not stop, it’s an inherit problem in the firmware.

  3. See if the router can be flashed with dd-wrt.  Just checked.  No listig for WD.  Interesting tidbit: Buffalo is using dd-wrt on some of there routers!

Update:  I believe this is resolved.

I did verify that turning off SSI Broadcast on thr 5hz does indeed turn off WPA2 security on the 2.4hz band…  but, only momentary for half a second or so!

I use ‘Wifi Analyer’ on my Android phone to monitor networks.  WPA2 dissapeard from the 2.4hz network and I paniced!  If I would have waited for the 1 second refresh I would have seen WPA2 re-appear.  I was too quick and paniced.  But really!  Why should WPA2 dissapear when turnnig off SSI, even momentary!  

Wow!  If i would have blinked I would never have noticed and saved several hours.  But, it is interesting.

I’m on the MyNet 900 now.  5hz is turned off.  All apears to be fine.

As commander Worf once said:  All systems operating within established parameters.

This is just a guess, and I’m assuming you are using windows

Open Network and Sharing Center.

On the left:  Change Adapter Settings

Right click your wireless Network Card…choose Properties


Advanced Tab

Wireless Mode :Choose either 802.11 a/g or 802.11 a/b/g

Ok out of all windows

You should now see the 5gHz Connection

So - did you ever get 5G to work? If so, what did you do?

You could try reflasing the router with the latest firmware, perform a full reset, then go from there.

My n900 has the same problem with the 5 GHz band. I have WiFi Analyser on my cell phone and the 2.4 GHz bands both show up (very well, in fact. Excellent signal strength) but no 5 GHz. I noticed there is a setting as to which channels WiFi Analyser looks at for 5 GHz and I made sure all were selected. My daughters netbook also does not see the 5 GHz signals (either the regular or the guest, both enabled). I am waiting for an email from tech support, but all I have gotten was the automated reply that the case has been created. I am not expecting much.

I have two N900 routers and on one of them the 2.4Ghz won’t work.  The 5Ghz works fine on both.

On the other router the 2.4Ghz band is working fine, so I know it is not my other wireless equipment.

Have reset (hardware and software) unplugged, changed names, turned security off and on.  I upgraded to the latest firmware on both routers.

Nothing will get the 2.4Ghz transmitter to show itself.

The only thing I haven’t done is flash the firmware again… but don’t know why that would help.