N900 Just stops, requires power cycle

It’s only happened once so far but this is very strange… after staying up to 2am to get everything working (and I did), I came home today to find I had no network… wireless or wired.  I had to powercycle the N900 to get anything back.

Any reason why this would happen?  I have latest firmware.  Any settings you suggest I disable to make this more stable?



Hi, don’t really know, just in case check the power cable, if you have it connected to a power surge, try using the wall socket directly. 

I have this same issue - happens once or twice a week.  It has got more frequent with the latest firmware release

This happened to me the day after I connected my 2nd N900 as an access point…but it was the primary unit that died.  Had to reset then it worked fine (going on 3-4 days now).

If there are others who mysteriously have to reset their routers, please add on to this thread.  There may be unforeseen problems.


Update on my side… I had turned QoS off for a few days and it hasn’t happened since (although the post about once a week is concerning).  But because of issues I"m having streaming video via DLNA I’ve had to turn on QoS - that hasn’t solved my streaming issues (see http://community.wdc.com/t5/WD-Networking-Devices/Optimizing-for-Video-Streaming/m-p/519158) but I’ll keep an eye on whether it causes my WLAN to stop working again.

I have the same problem after setting up the N900.  I updated the firmware during my setup so I don’t know how it performed prior.  Sometimes only a few of my devices would stop being able to access the Internet while still being able to access the WiFi network and others would stop responding to the network altogether.

When playing music from my iPhone via WiFi, I would get periodic drop outs and would have to reconnect WiFi which did not always work.  A reboot usually fixes this for a day or so.

2 days ago I turned off QoS and so far, I have not had to reset it.  This would be the 2nd day going on to the 3rd day without reset.  QoS may prove to be the issue.

I am having the same issue too. I have had to reset my router a couple times a week and the last couple of days I have had to reset it a couple of times a day. I have already turned QoS off, but that hasn’t helped.Today I had to cycle the power three times to get the network back up.

Hey all - glad to see this thread and that I’m not alone either.   I too updated my firmware during setup so I don’t know how it ran prior to the upgrade.  I have had to power cycle it 3 times now in 4 days.  I haven’t changed any of the settings regarding QoS or tried other items.  Hoping that WD monitors this and posts a firmware fix soon. 

I have had similar issues with it.  Happens about once a week.  Either the wireless nextwork is completely dead (can’t detect its SSID), or devices say connected but can’t get on the internet.  Always required a reset to get it back alive.  I have tried disabling QoS and port forwarding but they did not help.  I just started disabling the 5GHz band and it’s been ok so far.

WD needs to fix these issues.  Users should not have to disable advertised features to have a stable router.  We could have paid a lot less and just get a basic router.

Mine does this also… I have not attempte disabling the 5Ghz…   

I just power cycled it again just now so I will give it another chance… if it happens again I will try the disabling 5Ghz.

I noticed tonight that it happened right after a particularly heavy burst of traffic from my Macbook Pro which is using the 5Ghz connection.   Time Machine (The Mac backup software) kicked off and within minutes the N900 lost all wireless… and even my wired desktop could just ping it, but not bring up the web based administration or go out to the internet.

Also… my N900 Central makes a noticable “Click” noise every now and then… does everyone elses do that also?

I’m having the same problem. The Router Stops working, and I have to power cycle it. It’s happened multiple times in the last 2 weeks. It ran without any problems for 6 weeks prior to that. There have not been any changes to the settings.

Was there anything new device/traffic introduced to your network or a FW update? What version are you running?

Funny… I first logged this and then it never happened again. However it did happen again and was when I overloaded wireless traffic. I was streaming a movie to my tv, and at the same time copying a a 5gb file from my laptop to my MBL. Everything shut down. The file copy was on 5ghz. Had to power cycle.

Happens to me too.  I tried disabling QOS but didn’t notice any difference. 

I too have had this issue, and I have tried everything that has been listed in all these posts.  I have always been a fan of WD even when they weren’t so popular, but when I purchase something that gets high reviews from industry hacks… I expect that it live up to the hype.  I updated the firmware and I have a WD paper weight 65% of the time.  I would hope that WD gets this fix REALLY SOON!   I loved the idea, right now after 3 weeks of pain and suffering for my home schooling family and me as a full time IT professional and student I hate the result.  My opinion can be changed and I hope it is but I would not recommend this product at all till WD get this fixed and right.

Well I tried disabling 5ghz…   still locked up…  haven’t tried disabling QOS… but after reading other users’ unsuccessful attempts to get this router stable by disabling services… I guess we are all just stuck waiting around for a fix.

I can tell you one thing… when my Macbook is trying to run a Time Machine backup… the whole network is really fragile and slow…   internet access, etc… it’s like the router is being slammed with traffic or something.

Please WD… fix this with some firmware update… I really REALLY want this thing to do what it says it should.

Lots of great reviews… I guess nobody actually used one for a week though. :frowning:

yourguide - Do you have the N900 or N900 Central? Is there any new traffic/devices in your network since you starting seeing the router issues?

I have the N900 Central.

The commonality I can find is it seems to do this when I am performing a Time Machine backup from my Macbook Pro Retina…I have tried it on both the 2ghz and the 5ghz spectrum… both places seem to overload the router to where it just stops responding and needs to be reset.

I have disabled Time Machine backups via the N900 Central and will run it for a few days like this and see if that’s narrowed it down.

I tried the suggestion by turning off (deslecting) QoS and have not had any issues for the past week in this regard.  My only issue now is if I am using the attached hard drive on USB1 and transferring files and another person goes on the internet, my N900 requires a hard reboot.  I consider this as a CRITICAL issue that WD needs tro address immediately. With all the posted common issues, I would think that WD would have some feedback comments as to what they have found and when we might expect fixes.