N900 gives terrible iPad performance

Hi folks

I’ve recently upgraded from a Billion 7800N router to the N900. I’m using the 7800N as a modem, with the N900 handling all Wi-Fi and router duties.

I’m getting terrible wireless performance on my iPad 1. The room I use it in is about 7 metres from the router, with one wall in between, and the 7800N’s Wi-Fi used to perform fine under these circumstances. However, the iPad times out when trying to access any web page when I’m using the N900 for Wi-Fi. I’ve found that disconnecting from the Wi-Fi network and then reconnecting seems to solve the issue for a short period of time, and the connection strength on the iPad is also listed as the full three bars. This suggests that it’s not a connection strength issue, and is more likely to do with the N900’s configuration.

Note that I’ve tried the following troubleshooting steps:

1.) Updated to the most recent firmware available for automatic download via the N900, as of 2 days ago

2.) I’ve set the Security mode for both frequencies to WPA - Personal

3.) 2.4GHz frequency is set to Mixed 802.11 b+g+n, while 5GHz frequency is set to Mixed 802.11 a+n.

4.) Both frequencies are set to Auto Channel and 20/40MHz (Auto) Channel Width

5.) I’ve also disabled the routers’s Fastrack QoS due to issues

Any ideas? I’m on the verge of returning the new router and going back to my much older, much cheaper Billion 7800N, so hope I can find a solution here.

Yeah I get the exact same issue every ~30-40 minutes on my new iPad (iPad 3). My wife will be on her laptop with no problems, but I’ll have servers time out; after a minute or so the problem “heals.”

Hi, have you tried disabling the Security for at least one hour to check if the problem continues?

I would disable the auto channel.

I’ve seen it cause alot of problems on many makes of wireless routers & wireless modems.

1 Like

Thanks guys, setting the channel to manual seemed to have done the trick, problem solved!


i have the N600 model and would like to try to set it to manual but there doesn’t seem to be an option for that. 

All I want to see is if there’s any difference with the ipad experience