N900 from AP to router mode

I was experiencing some issues with my n900 and decided to try a bunch of settings, one of them was to set the device to AP mode.

Offcourse this was a dumb thing to do as the n900 actually was my router and i wanted to change the mode to router again.

The problem is, i cant reacht the device anymore, not on the IP address it had ( and not with wdap command. I thought, lets reset it, but that doesnt seem to work either. atleast i think it doesnt, its still broadcasting the SSID it was before i tried to reset it.

i tried the wd install tool aswell but still no result.

Could someone please help me with this issue?!

thanks in advance. BTW im not a complete it noob so no need for layman’s terms.

  1. Power cycle the router, let it boot back up

  2. The configuration page should always work, provided you know the address

  3. Press and hold the reset button on bottom for 30 seconds with power on, while looking at front panel lights, it should reboot once button is released, if not you did not hold long enough

  4. After the reset, reconfigure,  starting with basic settings

do not change a million items at once.  Get it operational,  then make small steps until you break it, this way you know what went wrong.

you need router mode, you know this now.

Out of the box set the following and test for stability…

  1. Adjust wifi security to either wpa or wpa2, not both combined.  This has caused numerous problems for me

  2. Set wifi passwords

  3. Change admin password

  4. Use the router as is to determine stability with minimal settings and some security.  If you can make it through a couple of days of normal abuse or a few hours of ridiculous downloads or transfer, then go crazy tweaking for optimization. 

  5. Do not use the usb ports for hdd during this time.  I have proven numerous lockups and crashes as a result of extreme usb hdd use while using non external powered hdds.  The hdd overloads the router power supplies and pulls it down and locks up the router.  This only happens with non external hdds

Thanks for the reply, just for the record, i did not change a million things at once, i did it one at a time. 

I should try resetting it again holding the reset button as long as possible bfore releasing the reset button. 

I still think its weird that i can’t reacht the webif anymore after changing to AP mode. 

Again, thanks for the reply and will try this when i get home (at work atm). 

Edit: Tried to reset the router again, but it wouldn’t. It wont let me reset it.

I had the same issue.  I replaced my N900 with another router, and attempted to switch the N900 to AP Only mode.  Since doing that, I no longer have access to the web admin.

After changing it to that mode, a warning does come up that says to switch your WAN port to a LAN port.  I tried connecting to both with no luck connecting, even from a wireless connected client.

Just as an update, I had to factory reset the device first.  Then I was able to reconfigure it as an AP only device.  In addition, the message that says to plug the WAN cable into your LAN appears to be incorrect.  I could only access it via a LAN port.