n900 + fasttrack

Hi guys ,

Ive got a n900 with the lastest firmware , upload is set to 1 meg . All machines connected gets stuck on waiting for reply and never load any pages .

Turning off fasttrack fixes this and everything works normally.

Seems the auto classifications are bugged in some way .  I left my laptop on for 2 hours and it didnt get a reply from www.autosport.com. Turn off fasttrack its then instant .

As everyone else says " i bought it for the fasttrack plus "

Ive had every family version of the ubicom cpu and as this is there last one i thought i would give it ago . I have never seen the qos do this on any of the other versions, so it must have a bug in the firmware .

Looking forward to a new firmware that fixes this issue


Did you tried resetting the n900?

Yes ive tried that , ive turned off the auto classification and made a high priority port 80 but its still the same.(all put back to default).I tried putting a 40 meg upload just to see what would happen but it was the same.

I use two routers , the n900 as main and a dir-655 as a wirless ap . The odd thing is my machine works fine , as does my brothers which are both on lan.

Two android phones dont work on wireless and nor does my mums laptop but my laptop does ? They always stall with waiting for a reply . My blackberry phone works on the wirless fine!

So some of it works and some doesnt , seems the fast track  is broken .With fasttrack off everything works fine and until its fixed the fasttrack will have to stay off :frowning:

I replaced my other router / direct swap with the n900 , my ap router wasnt touched at all .

I dont use the n900 for wireless as its in the basement of the house , i did try the 2.4 ghz but my mums laptop still wouldnt play ball with the fasttrack enabled.

All in all very odd!

Lets hope the next firmware can fix this soon !

I have managed to fix the problem i was having :

i did it like this :

turn on fastrack

turn on auto classification

put upload to as many 9999999999 kps as u can get


let it reboot

try to login to router , says error 500 in web browser.

turn unit on/off

start surfing all pages load up at the correct speed

log back in and change fasttrack upload back to your real upload speed ie 1024 in my case.


this has fixed it for me , why i tried the 999999999999 kps was on smallnetwork builder review of the n900 ,wd confirmed that without fasttrack on u dont get hardware acceleration , so id rather bodge the upload so if would aleast have that enabled.


fingers crossed , it stays like this , everything so fast now web pages are virtual instant

let us know if it works for anyone else

just stuck in the new firmware , factory reset , same problem.

had to repeat the same process