N900 Central Router hangs after many packets in short time


#1

Hello,
The WD My Net N900 Central Router hangs (turns off) after the computer sends many packets in a short period of time. It later comes back, but it takes half a minute or so, and the connection is lost (so I cannot use the internet properly). Has someone faced the same problem? Details:

  • Tried both with wireless and wired, same problem.
  • Tried with different OSes / computers, same problem.
  • Tried in different scenarios (Dropbox with many updates, sending large emails, etc). I know the issue is with packet flooding in the router because if I put a packet limit in Dropbox (via software), then it works. Without it, the router hangs. It does not happen at every connection, but when happens it is a moment of many packets being sent through it clearly. Surely happens with TCP packets, not sure if with UDP too.
  • I am using the latest firmware (or so I suppose: 1.07.16 of 12/Apr/2013), and a very basic configuration of the router (I have changed that in every possible way, but no fix to the problem).

Thanks in advance!


#2

Reboot the router, and does situation improve?


#3

Thanks for replying. If by reboot you mean just to turn off and on again (citing IT Crowd here :-)), I have tried that, and actually it does exactly that when it gets too many packets too fast. I have also tried to reset…


#4

Yea remove all power – unplug it for a few minutes. Then do same for modem. Restart modem after a couple of minutes, then restart router.


#5

Thank you for the effort, but this does not help me. As I mentioned, I had tried to reset the device before. I have tried now speedtest websites too, and the router hangs too on those. There is clearly a problem there, and I would like to know if this is an issue of my device or a known issue with this N900 central router. Is there anybody else with a similar problem?

Note that I have direct fiber connection through other main routers with a few hundred Mbps both directions (download and upload, no “modem” here). I believe N900 breaks down only when speed goes beyond many tens of Mbps (at least) and only for upload. I know it works if I restrict my connection to 10 Mbps, for instance, but that is not ideal at all.


#6

I have no idea, so contact WD.


#7

Thanks. It works fine if I limit upload bandwidth below 100 mbps, so for now I will simply do that…