N900 Central - DNS Proxy

Bought the router a week ago, updated firmware to 1.07.16 and set it up as a DHCP server with a dynamic IP connection from my cable modem. Soon enough I noticed that computers in the network would loose Internet connectivity at seemingly random intervals of time.

A simple test revealed that i could not ping a domain name, yet i could ping it’s corresponding IP, so it was a DNS problem.

The solution for me was to disable the DNS Proxy feature of the router found in Advanced setings > LAN > Host and LAN Settings. It comes enabled by default and as far as I understand, it makes the router behave as a “local” DNS Server.

This is just a heads up: if anyone is experiencing similar symptoms, give this a try.

1 Like

Hi and thanks for sharing. 


I am having the same problem as the above user, but I don’t have the settings you list above in that area.

In LAN/Host and LAN Settings, I only have Host Name, LAN Connection Type and Enable as Local Master Browser.

Do you know how I can get to the settings you mention?


OK, I had it set as access point only, and have now found that setting, apologies.  I still have the same issue though unfortunately.

By having the same issue you mean Internet connectivity seems to be down, but you can still ping outside servers using their IP adress (successful ping to for example)?

If this is indeed the case, after disabling DNS Proxy (and rebooing both router and devices just to make sure), in Windows enter Network and Sharing Center, click on the Connections link, then click Details.

In the Network Connection Details window you should be able to find the allocated DNS servers. If the DNS IPs are the ones allocated by your ISP, then you should be fine in that regard and the problem may lie somewhere else.