N900 and dropped PPPoE connection

Just bought the N900 yesterday, replaced the old router (WRT610N) with this one.

I connect through PPPoE with Bell Sympatico, I tried to use the same settings from the old router but it drops the connection constantly though the router reports the internet as “connected”.

Those are the two option in the old router, which works all the time.  I use the second option ->

Connect on Demand: Max Idle Time         Minute.

->Keep Alive: Redial Period    30    Second.

The new router has 3 options:

 Always ON 

 On Demand

 Manual

Maximum Idle Time(minutes, 0=infinite)

Tried all three methods and, after a minute or two, all will drop with the browser saying “Waiting for www.whatever.com…

Tried on Demand with maximum idle time of 0, 1, 15, no change.   Everything will work for about a minute right after I make a new selection.  When I plug the old router back in, all works as it should.

Just seems like the implementation of PPPoE is not working, as it always indicates that there is an internet connection while there isn’t.

Connection to Internet               Connected

  • I have the latest firmware (Firmware Version 1.03.11)
  • tried both DNS from the ISP and manually set to OpenDNS (as it is currently).
  • tried Always ON, Manual and on Demand with 0, 1, 5 15 minutes
  • ISP is Bell Sympatico (Canada)

It’s about to go back to the store if I can’t get this PPPoE connection going!

This sounds similar to the problem I’m having.  I’m also on Bell Canada.  Try disabling FasTrack Plus completely in the advanced settings.  This is the only thing that works for me, otherwise I get the same thing in Firefox as you seem to be having “waiting for…”, forever.

This is the thread where I reported it, but I can’t find a solution either:

http://community.wdc.com/t5/WD-Networking-Devices/New-n900-Router-Issues-with-FasTrack-Plus/td-p/434236

1 Like

Wow, thanks, that did it…

The instant it was turned off and rebooted, all websites instantly loaded.  It’s an easily reproducible snag, so WD sould be able to fix this soon (a mix of hope and sarcasm).

The FasTrack Plus was the whole point of getting this router, so they now have 27 days to fix it before it’s sent back.

Will follow the other thread.

Yes, FasTrack Plus was the reason I bought mine too.  I was about to return it and try another one, with the assumption that mine is defective - since I didn’t see anyone else here with this issue.  Now it seems more likely that it’s an issue with Bell Canada/Sympatico (or their modem) and this router.

So I guess the question is whether or not WD can pin this down and fix it with firmware, or if they even read these forums and see this.

I’d rather not return it for another brand it if they can fix this.  The router works flawlessly otherwise - even under heavy load.

Started an email support ticket: 071512-5695519

I hope too they can fix this, getting very good speeds and stability otherwise.

Only big disapointement is lack of support for “Time Machine” for my mac laptop…No AFP, only SMB for attached USB drives.

I filed an email support ticket as well.

I’d guess I’ve got about 20 days left on a 30 day return policy.

Well, so far no response from support email… and no forum response from a WD guy (altough they are active in other posts)…  so much for “a response within one day”

Hi,

Someone brought this to my attention.  We are going to look into it.