N900 2TB: Large File Transfers Go Slow and Crash Router

File transfer speeds going about 1mb a second via wired connection, after about 10gb’s it crashes the whole router no lan connection, no wireless, no access via browser, or wd2go app.  I tried taking a smaller flash drive directly into the back and transferring from there but I’m expeirencing roughly the same speeds.

Currently I am running the newest firmware,1.05.12.  Does anyone know if the previous firmwares are any better?  Should I downgrade? 

All WD support had to offer via email was to update my routers firmware… thanks been there done that and dear support, read the emails we send you, then reply!  Fairly pointless to have a router that has a harddrive in it if I cant transfer to it.

As per Bill, a factory reset is a must after a firmware upgrade. I will try that in a couple of weeks.
For now I downgraded to 1.04.11 and I am getting about 4-5 MB/s transfer rate.

It really sounds like you are suffering from the overheating issue I had with my N900 7xgb port version where under any large file copies, it would crash.  propping it up on a cd case helped me get 20gb or so before crashing and finally I used a laptop cooling pad.  Since installing the pad, I have only had to reboot the router once in 6 days and that was because the DLNA server stopped while all other features remained up.

With the newest firmware 1.06.18, I tried to transfer a file from the N900 2TB to my harddrive. The file was 1.2 GB and the transferrate was pretty stable at 24-25 MB/s which I find very acceptable. This was by cable.

Just wanted to let you guys know it was a heat issue.  Went out and bought laptop cooling fan and stuck it underneath the router which is on a shelf with about 2 feet of clearence on every side and that did the trick (transferred 62gb with out a hickup at about 10mb a sec on v1.05). 

Way to make something that over heats when you transfer to it western digital.  After buying this router I will seriously consider buying another brand for my hard drives if this is the kind of a work around we have to do to get your products to work.  Its a serious flaw if a fan is not coming on and something that should have been hotfixed if its a firmware issue and I am assuming its firmware and not hardware becuase of the ample amounts of posts about it.

Glad the cooling pad worked for you like it did for me on my N900.

Yeah, what is this talk about a factory reset after a firmware update?  I seem to have “lost” my internal storage again, this time after upgrading to the latest firmware.  yes, you got that right…the INTERNAL storage now can’t be seen by its own **bleep** router.  Nice job guys.  Now how Do I get the router to see its own storage again.  BTW, I can still see the share I had created before in Windows explorer, and listen to songs from it, and see some of the pics from it.

What a huge hastle this whole thing has been.  if this isn’t resolved quickly, this will be going back to amazon.  Don’t care if it was a good deal…it just isn’t worth it.


SMB (Windows Explorer) can see the files but DLNA client cannot? Have you tried the reset to defaults?