N750 Drive Not Functional With iPhone or Android File Share

The USB drive attached to my N750 is not accessible via Android or iPhone systems. With assistance from OS6 based FileBrowser developer, we determined that the router’s SMB app is either a very old version or is not correctly functioning. Note that storage share works ok with my WinXP, Win7, and Win8 systems (NetBios). This router replaces a Belkin 4181 router that did not have this problem.  While I wait for assistance from WD’s 2nd level support, I’m wondering if anyone else has run into this.

Hello, do you have the option to look for the external hard drive by name, using \mynetn750"external hard drive name"?

Yea, tried that but it’s not the problem.  As it turns out, after many hours, working with 2nd level support, they’ve been able to reproduce my problem with not only the N750 but also the N900.   I’ve also discovered there are problems trying to write to the drive with Windows command line apps like XCOPY.  Gets an error which translates to "network server does not accept remote requests’.  If memory serves me this was a very old Samba issue.  They offer no fix at this time.  Since I bought this from Staples back on 12/31, I will return it as defective.  I’ve spent way too much time on this.   Adios WD routers.

Same issue here. Unable to play anything from my USB device connected onto the routers USB interface. I really hope they get this fixed on the next update. This is very annoying.


Is SMB share working properly with Linux ?


I have just purchased a new WD N750 and was horrified at the posts about the android not being able to play video… this is the sole purpose of me purchasing the unit… my heartache was shortlived… downloaded app “mediahouse” from the market and it was as simple as that… currently performing stress test and no problems yet… MKV files seem to take a while longer to load … but they they do load…

My setup is a samsung 2tb HDD into usb port 1 … android device = Samsung S3

android app market - mediahouse- shud work… good luck

I have the same problem. Bought this WD N750 yesterday and setup quickly with not a problem. I have a Toshiba portable HDD connected to WD N750 with all MP4 movies. I tried the “FileExplorer Free” App and AcePlayer App on Ipad2 and was able to connect to my HDD with no hassle. I found the movies (all in MP4 format) and I got this message when I tried to play them all.

“Unknown Error - The movie is not able to be played due to an unknown error.”

Really frustrated with the outcome.

HELP! HELP! HELP! Western Digital must resolve this problem ASAP.

There was no such problem with my previous Netgear router at all. The only drawback is a single USB port.

I don’t know what the WD tech geek has done but it works.

  1. install the “Oplayer” App from Apple store,

2. Goto Advance Settings/Storage - under Share function for storage - check all boxes.

  1. Under Storage access permission - check Public share

Then it works. It is definite not the best solution and the movie is “watchable” but not always smooth.

I discover that the N750 uses port 139 on Samba (very non standard) and normal popular router, NAS and similar would use port 445. I wonder why? All comments and suggestion would be mostly welcome. Tech guru should be able to answer.

Hope the next firmware update would resolve this issue.

I have a N600 router and am having no end of problems trying to connect to it with my Ipad and Android tablets. Put 'Filebrowser; on the Ipad and it just wont connect.

Reading here about the SMB Samba issues seems this is the problem. Firmware is from December 2012 so seems that one has not fixed this issue.

I tried the different port number per the post here but makes no difference. Tried changing from port 445 to 446 and with NetBios turned on and comes back NetBios time out.

I can connect using the Windows Laptop no problem and with DLNA connections but not with SMB.

Can anyone offer help? Also is there a free IPAD app that might use SMB to see if indeed it’s the router or the Filebrowers IPad app I am using?

All help appreciated. Not sure why WD have not sorted this out. Was the reason I bought the thing!


My experience is very limited but it works for me on both Android and IPad. First remember the external drive, I presume this is what you try to gain access, takes time to index. Somehow it takes longer to index than other brand. My previous Netgear almost didn’t require indexing. This is the area WD must require to resolve. Leave it overnight would be the best.

It seems always work to use the IP address of the router rather than the name. Ie. Default address and port 139. This is the ONLY port that works on both SMB and FTP in the App. It works on both Android and iPad. To be honest I am an Apple Fan and it works far better than Android. Android apps are very buggy because there is no rule and no control of quality. Apple apps depend on the quality of the app writer. Sorry too much info.

Give it a go and good luck. Mine works and THE support guy was extremely helpful.

Hi Noramando

Were you using the Filebrowser App on Ipad? I tried the settings you say but no luck. What settings in the ‘advanced’ section did you have?



I tried the free app “remote file browser” and I saw the problem. I can access the hard drives and drill down to the folder. But somehow I cannot access the file. I don’t know why. Maybe you need to talk to the developer. I have no problem with free app “Fileexplorer” and I have no issue at all. Give it a go. It is free after all.