MySQL access

Can we get the config changed to allow connection from anything other than 127.0.0.1? If the sql in installed on, for instance 192.168.x.x should be able to access from any machine in the subnet. Ability to host the database

Current iteration using my.cnf located in /etc. if you change bind-address to 0.0.0.0 or something in the 192 class it’s overwritten by the my.cnf stored in /var/usr/local/modules/etc. this was possible in OS3 should be able to in OS5

2 Likes

@Wirehead
phpMyAdmin doesn’t support remote access on My Cloud OS 5 and it is restricted to localhost.

For more information, please refer to

Understand, but not trying to access phpMyAdmin remotely. Trying to access a user-created database. The request can be addressed by WD changing the permission on the file in /var/usr/local/modules/etc to allow modification of the my.cnf file. This would allow the bind-address to either be changed or commented out. Then when the system is restarted, the change would stick and the database could be accessed from other machines.

+1000

Why on earth they disabled this? What’s the purpose of the myql server if we can’t do anything with it? As stated, we could access mysql from the network in OS3, why its forbidden in OS5? The are cripplig the device

Hi , access to SQL must be possible. No sence to have a device with an database without access from other devices. It’s a bug, not a feature ! .
In phpAdmin I can setup users for access except localhost.
My complete homeautomatisation is running an this ! now with OS5 is dead.

2 Likes

Exactly! I’ve had numerous conversations/chats with support to no avail. They just say its a OS issue and they can’t divulge any commands that might be used to remedy the situation. As I was looking for something with some more options and hardware specs… I have dropped WD and moved over to Synology. Way more configurable OS and with Docker support so take that for what it’s worth. WD lost another customer based on their decision to not work with users to find a solution. In my opinion, while I understand certain changes were made as security remedies, much of the OS has been crippled.

I have same problem, Mysql database is running on mycloud but I need to connect to it from my machine to kodi

I need it to be access from any ip.

It’s very stupid that it got disabled. I use to connect my NAS and maintain a single phpmyadmin for all my projects ! With this now i can’t access it anymore

I wonder if anyone would be able to modify the web server Apache so it can allow external IP. Unfortunately Windows user have no access to decide internal apps folder

Thank you dswv42 for your reply.

I was reading all your finding yesterday and as i’m a Windows user, i dont have that much experience in linux commands. However i will google that and will figure out how to find the device name per your command

/usr/libexec/mysqld --basedir=/usr/share/mysql --datadir=/mnt/HD_a4/.@database@ --plugin-dir=/usr/local/mysql/lib/plugin --user=root --log-error=/mnt/HD_a4/.@database@/PR4100-DEV.err --pid-file=PR4100-DEV.pidroot@PR4100-DEV &

Thank You for update, i figured that out ! However in this way i guess i need to disable the Power Schedule and make the device doesn’t turn off at all

Will hopefully we can figure something out about it on the long run

Ahaa similar to Autoexec in windows ! Great then will try it out tonight. Appreciate your time and affords

In new firmware Update this has been fix by

Go to Settings → Networks → change Network Database to “On With remote access”