MyPassportStudio bricked after 1012 firmware upgrade

Hi All,

I’ve just receive a new MyPassportStudio in substituion of another broken :frowning:

I upgraded the firmware using FirmwareUpdate to upgrade to version 1012,but after reboot the device is no longer regognized as a valid wd disk. Now it’s composite device.

How can I solve this?



Did you follow all of the steps on power cycling the drive? I don’t know a lot about Macs. In the past some people with Macs had to update the firmware on Windows to make it work. I know it sounds dumb.


tried on windows (both 7 and xp) but the updater crashes

I have the same problem with my Passport Studio - the firmware bricked it on my mac and I tried to fix it by updating the firmware on a Windows  pc but it keeps crashing - any ideas?


Dear All,

I have the exact same issue.  I am now on my THIRD RMA replacement drive.  The guy on the phone ensured me it would come with the latest firmware installed before we receive it.  Its a bit ridiculous that Western Digital cannot fix this problem.

This firmware fixes incompatibility issues with Lion, however if you already use Lion, this firmware will BRICK your device.

stupid.  Any updates anyone?  I will now wait another 5 days for ANOTHER RMA drive and will get back to you.