MyPassport Ultra back up doesnt work since windows 10 upgrade

Hi, I have WD My Passport Ultra (wired) external HDD. My laptop recently had windows 10 upgrade (from windows 8.1). Since then I am not able to back up. The drive is visible in windows explorer. I can see ‘WD back up’ icon in in-tray on the laptop (bottom right hand side). When I right click select backup now ; nothing happens. Only options that work from the drop down menu of ‘WD back up’ are Help and Quit. Setting, Back up now etc do not seem to do anything !! My last back up is few weeks old so worried about it not working. Any solution to resolving the issue will be greatly appreciated.

Your version of WD Backup may need to be updated since you have changed your Operating System. I’d recommend uninstalling the current version from your list of programs, and installing the latest version directly from WD’s site.

Thanks. I just solved the problem–I needed to format the drive. It’s fixed.

Hi, Thanks for the information.

Here is the update

  • I downloaded and installed latest ‘WD Backup’ software from WD website.
  • It was encouraging that after completing installation it offered me the option to ‘use existing back up plan’ OR ‘specify new schedule’. I selected existing plan. (I even tried to amend the existing plan in a separate attempt).
  • it gave option to ‘back up now’ which I selected.
  • Still nothing happens and I still can not open the ‘WD Backup’ console from the desktop !!!

In short problem remains. I DON NOT want to format the drive as surely I will lose existing data from the ‘My Passport Ultra’ device.

Any further ideas please?