MyPassport not recognisable after firmware update


I recently found that my 500gb My Passport external could not be recognised when using the firewire 400 - 800 cable (via multiport hub or external soundcard).  However it was working with firewire 800-800.  I decided to install the last firmware update after a reformat to see if this fixed it but the update failed and now the drive is not recognised when I try plugging it in with any cable.

I tried reformatting in windows but windows fails to install the driver and subsequently can’t reformat.

I’m running Mac OSX 10.6.8 on a macbook pro.

Thanks, any help much appreciated

Its a My Passport Studio by the way

Did you try running the firmware update from Windows? If the firmware got corrupt the drive is probably bricked. Call WD if it’s still in warranty.


Yeah windows sees the device plugged in, it was an unknown device so installed the SES driver, it now recognises it as a WD device but not as an external hard drive.  The windows firmware update doesn’t find the drive not does quick format - tried formatting through the disk manager but it’s not recognised.  Have a feeling it’s not still in warranty…

I think I know why the firmware might have failed though - I’ve noticed that if you move the usb cable very slightly it loses power, some kind of loose contact - i think it must have turned off momentarily during installation

No chance of getting this drive recognised by anything for a reformat then I guess?