MyPassport critical issue - what can I do?

Hey there!

My portable MyPassport has given up on me and makes the infamous clicking noise. It doesn’t seem able to spin up.


  • the controller is fine and communicates with my windows
  • nothing can be read from the drive, it clicks and stops after a few tries

what I’ve done:

  • I panicked (jk)
  • I’ve tried remounting the device several times
  • I’ve tried fixing it with gentle tapping on the device, didn’t do much either
  • I’ve tried running a SMART scan on it (WD Utility recognizes the drive), but it failed obviously
  • made a support case - no reply for days

I’ve been told to get in touch with data recovery centers or, do it myself by taking a look inside the drive and

void my warranty by doing so. I first planned on waiting for WD’s response, but I seriously need the data on this disk

(+300GB). I know, I should’ve made a backup, but the drive itself actually was a backup for a long time, but I removed the original data on the other devices already, making it just a portable drive… sad face

Not sure what I should do now, any ideas? I just hope the disks aren’t scratched by the heads or something…

Sorry to hear you can’t access your files, have you tried some troubleshooting steps like using another USB cable or connecting it to another PC.

  • I haven’t tried another cable, as I do not have a similar cable with a plug for extra power. Is there a possibility that something’s gone wrong with the power plug attached to the HDD?
  • I have tried connecting it to usb hubs on the back of my motherboard, I’ve tried connecting it to several other computers but the same behaviour occurs with every single one of them. I’ll try it on the last remaining computer in this household right now actually, who knows. ~Edit: no success, same behaviour

It’s quite painful to know that my data is actually in reach, but there’s no way of accessing it right now (if the platters are still intact, that is), I guess I had it coming as I’m guilty of not creating backups anymore.

If the drive just clicks then most likely the heads or the pre-amp inside the derive is damaged.

DO NOT OPEN the drive if you need the data out of it.

Take the drive to a reputable data recovery firm near you.

Sometimes some firmware issues might cause this sort of clicking as well, but there is no way to be sure without testing first with (very expensive) tools.

The more you power on the drive the less the chances are that you will get the data back, in case the heads are scrapping the platters.

Regards and good luck.

1 Like

Yeah I’ve been trying to get in touch with a ‘reputable’ company but haven’t found any yet, for Belgium. Quite a let down. I haven’t turned it on since my previous comment, neither have I opened it, just hoping I’ll find some way to recover it.