MyNet900 QoS

So does this work at all? My tests this evening suggest it doesn’t. I set my VOIP traffic  to high priority and my NAS and Torrent traffic to low but still both the NAS and the Torrents can totally block out the VOIP and indeed any other NetBIOS or HTTP traffic on the network. The ‘auto’ function detects 512kbps even though by upload speed is 5000kbps but no matter what I set it to manually, it has no effect on the bandwidth consumption by the NAS or the Torrents. I’m guessing the automatic QoS implementation has a very limited packet recognition, the rule feature doesn’t appear to do anything. Is this just a completely useless feature?


Make sure that when you are setting the rule, select the precedence in which the
application or device sends data over the network compared to
other applications or devices. The default value is 1-Highest.

Also make sure that your router has the latest firmware.

Check the link below to get the latest firmware.

My MyNet900 is now an overpriced switch/access point and a dedicated pfSense server is taking care o the QoS/Firewall. No more VoIP problems. Thanks for the advice.

I think the QoS is effective up to 2000kbps uplink speed. A little experiment but you can try to set your uplink manually to 2000kbps (2Mbps), take out pfSense and see if that works.

I could not get it to recognize my VoIP traffic at any speed. Even setting the NAS server traffic to the lowest priority would still cause it to lock out all other traffic including HTTP or VoIP both of which were supposefly highest priority. Only thing that worked was using the QoS on the NAS to thottle it’s bandwidth but that’s what the router is supposed to do.