MyNet N900, expected temperatures; fan

I just purchased a MyNet N900 and have been experiencing hangs requiring reboots.  I suspect it is overheading and the fan may be defective.  I’ve never seen the fan turn on.

I found a page on the device that displays temperature and fan speed:


You must first authenticate with the admin user/password before you can go to this page.

It display information like this:

Firmware External Version: V1.07.16
Firmware Internal Version: d4ci
Bootcode Revision: 2823
Model Name: MyNetN900
Hardware Version: 
WLAN Domain: CA
LAN MAC: 00:90:a9:cc:2d:06
WAN MAC: 00:90:a9:cc:2d:05
WLAN MAC: 00:90:a9:cc:2d:06
Serial Number: [Deleted]
T: 54
RPM: 0

Which seems to indicate a temperature of 54C and 0 RPM from the fan.

Can someone tell me at what temperature the fan should come on?


1 Like

Hello, have you tried updating to the latest firmware?

1 Like

Yes, I am using the latest firmware version.  You can see that in the DevInfo.php output.

When should the fan spin up?  I’m running now at 56C, which seems kind of hot.


I’ve never heard the fan come on, but I can tell you this router gets pretty hot and all the reviews had me nervous.  That said, I’ve heard that going to firmware 1.03 helps, but then your file transfer speeds take a pretty big hit.

Still, you can always take matters into your own hands and install a bigger heatsink, which is what I did.  Mine maxed out at around 45 while transfering 2TB worth movies over.  So far everything is running great with the latest firmware, and I even have a 4TB installed on the spare USB port.

(Edit - I made some changes to the case cover, because was holding too much heat, and the temps at full load is now 41 ) :wink:

Firmware External Version: V1.07.16
Firmware Internal Version: d4ci
Bootcode Revision: 2823
Model Name: MyNetN900C
T: 41
RPM: 0


If you’re hitting 56C, then you can expect to see higher temps on large data transfers.

this is the old picture, I’ll take a new one soon


1 Like

Thanks Xtreme3D.  I’ll consider that.  

It would be nice if the fan just came on above a temperature threshold.  A larger heatsink so it can run fanless is nice, but it ought to work without overheating out of the box…


I’m glad I can offer a solution, but I know what you mean.


It looks like WD maybe washing their hands of these routers.  This has been going on for some time now, and if WD wanted to change the fan threshold, then they could of.  Maybe they don’t want any backlash about the fan noise, but the complaints of overheating and rebooting don’t seem to be a priority.

That said, I got this 2TB router for $84, and with another 4TB of storage, it’s a nice/power conservative media server that’s streaming my collection of movies and files to my family houses.  It was a small inconvenience that I had to mod it, but at least it will be reliable and quiet for now. 

I’ll keep my fingers crossed that WD keeps updating the firmware on these units, so let’s see what happens.

Here’s something interesting.   If you telnet in (using the authentication info  here), there are several fan related /proc files: /proc/fanspeed and /proc/fantimer.      echo “100 100” > /proc/fantimer gets the fan moving.  

I now show:

T: 36
RPM: 2407

 I have yet to figure out where to put this so that it occurs automatically after a reboot.



Jamie56, what you found is very interesting. I don’t care about noise (though even with the fan on 100% it isn’t loud) because I have a USB powered fan underneath a wire rack to keep it cool. The fan at full blast along with my USB powered fan underneath the router produces temperatures in the range of 32C at idle and 37C under very extreme load (multiple instances of NetStress running over both 2.4ghz/5 ghz wireless bands and wired). Without the fan running at full speed(or rather the fan running at all ever), the temperatures would idle around 44C and approach 50C under extreme load even with my “creative cooling solution.” I’ve spent about a week sorting through various settings and the temperature was still a little high for my liking, and I would get random drop outs of wireless connectivity and lose connection to the internet briefly under load. However, with the fan running at full blast I’ve found the router is very stable with little issues over the past 2 days. I wish WD would update the firmware once more to address some of the issues still lingering and allow us the ability to control the fan via the Web GUI. 

However, if you find out how to automatically apply this settings when the router boots I’d be very appreciative if you posted it! 

echo “100 100” > /proc/fantimer

It looks like anywhere between “100 300” and “100 1” give you the min - max fan speeds.

That said, it’s still kind of annoying to hear the fan running, but it’s nice to know you can always cool it down if you want, Nice find!

I actually modded my cover because it’s holding way too much heat, even with the heatsink, it’s now maxes out at 41 at full load with no fan.

1 Like

I ended up buying a small laptop cooler for this router to resolve this issue. It seems to have done an ok job for keeping it cool, but it should not be required given that the router has a fan built-in. 

Did either of you take a look at the samba part of this guy? I was trying to get a large HDD enclosure to work with this guy.

Link to WD Topic

I see that they added more notes in the article provided about the version of Samba this guy uses… Wish I could reformat and give ext3 a try.

No it shouldn’t be required, and I’m really not sure why WD hasn’t stepped up to this issues.  Also, I’m not sure why WD hasn’t added some simple items like these, and I’ve actually have fixed some of these issues temporarly, I need to script them on a reboot.

Static ARP for WOL.

Port-forwarding to the router’s IP (FTP & SSH)

Samba and FTP shares use the volume label, or atleast set the FTP user’s home directory to the /var/tmp/storage directory.  (ES File Explorer doesn’t work well with Androids)

Add more users and permissions to shares, atleast a guest account.

I hope my answer helped on the other topic.  Samba did give me some issues also on my 4TB drive, but it’s working just fine now.

Mine goes up to 64c transferring files via lan, is that bad?

The simple answer is yes.  Too much heat can cause stability issues, it can also decrease the life expectance of a product.  If you have a N900 Central, then you’re also exposing the drive to higher tempatures.

It’s better to play it safe if you want your router to last longer and run reliable.  I’m depending on this router to run 24/7 to stream movies and files to my family’s houses, it needs to be reliable.  That said, I needed it to run passive, because it’s sitting in my livingroom and that fan would drive me nuts. :confounded:

Heres what I did with my 900:

  1. I opened it up and I rewired the fan to the power plug so that it gets power and runs all the time.

  2. I drilled holes in the top of the case cover above the fan so it can draw fresh air in from the top

  3. I added some thick plastic feet off the bottom of an old computer case to give it more room to exhaust the hot air 

this seems to have solved my problems

I gave up on WD. Got airport extreme and no issues what so ever.

How did you rewire it?  I’d love to do this, what did you do?  Pictures?  I just did the telnet using putty and have DevInfo open, just watching the temp drop…  Currently at 4108 rpms, thank god!  I’d love to keep the fan on perminantly, thouh…  Might even do the heat sink mod and add a few more fans…  This thing used to be an awesome router, I’d love to get it working right again!  I’ve been using an Asus router running tomato but it doesn’t have the speed…

You can set the fan to start at boot with a script - no need to rewire it.

Hi Clerk,

i suggest you mean this telnet command : echo “100 100” > /proc/fantimer

Can you please tell me how to set it to the router at the reboot?


indeed the command you mention works or you could just issue this one:

mfc fan <highspeed|normalspeed|stop>

If you just want it to start revolving at boot, simply add “mfc fan normalspeed” after 109th line in “/internalhd/root/usr/local/orion/communicationmanager/communicationmanagerd” (not sure if the path is exact).


Is anyone else able to turn on SSH through http://myrouterip/OrionInfo.php?

I was able to turn on the Telnet service for the router, but the OrionInfo.php page will not show up (404 Not Found) for me to turn the SSH on and get into the files to command the fan on full time at boot up. I’m using the latest firmware from May of 2013.