MyNet N900 Central Router: the Perpetual Disconnect Machine?

This has really, really gotten very old…

A few months back, we got our N900 Central router and set it up.  For a while, it worked as advertised.  However, within the first two months the router decided to stop accepting wireless connections at random intervals, usually for 15 to 90 seconds at a time.  It would then let them back in for a while, usually for a time varying between 0.1 and 600 seconds, and then once again refuse all wireless connections for 15 to 90 seconds again.  We RMA’d that one and got a new one.

 The new one didn’t even last a week before it started having the exact same problem.  But now, the problem has gotten even worse: wired connections as well as wireless ones are experiencing the spontaneous unexplained refusal of access as well.  Indeed, wired connections cannot be used to configure the router at all now.  Any attempt to do so simply results in the router refusing to even process the username/password login information.  The firmware update claims to be the latest (12 Apr 2013), and I’ve already confirmed it’s none of the usual suspects (the problem persists whether or not the firewall is on, the IP address ranges are not set to anything bizzarre, there’s no other nearby networks with the same name, etc.).  Can anyone possibly provide some advice?  The “best” advice I’ve seen on the forums to date is “get a different brand of router”, but I don’t think that’s a very good solution…

EDIT: Things get even stranger…  On a whim, I decided to ping -t the N900 Central, and the results are not what I was expecting at all.  While the router is timing out about 5% of the time, the other 95% of the time it’s giving ping response times of 2 to 6ms.  Even at times when it refuses me access to the internet and the router both, the ping response time remains healthy.

A few people have had this issue of WiFi being very unreliable. For me, what got it to work was setting it in 802.11n-only mode for both 2.4GHz and 5Ghz bands.

I suggest the following:

  1. Upgrade to latest firmware 1.07.16

  2. Do a complete factory reset to and then enter all settings from scratch

  3. In WiFi settings, change to 802.11n only mode

By default the WiFi setting is b/g/n for 2.4GHz and a/n for 5GHz. When I left it at this default, I experienced a lot of WiFi disconnections and then refusal to reconnect. When I switched to N-only, WiFi connections became much more stable.

My suspicion is that the router and devices are getting confused somehow. Most devices are also multi-protocol compatible. What might be happening is that if both router are b/g/n compatible, they might be trying to communicate via different protocols and getting mixed up. By setting it to N-only, there is no confusion.

I should note that under old firmware 1.05.12, this problem was much less pronounced for me even with all protocols enabled by default.

1 Like

I have since discovered that at least a part of the problem is in fact a combination of my cable modem being in need of servicing by Comcast and my using the Google DNS servers.  Since then, I’ve narrowed down the issues with the router.  Connections are not being actively refused any longer, fortunately, but the router is still getting knocked offline at random intervals.  The intervals, however, are far less lengthy than before (the longest I’ve recorded since the changes I made was about 30 seconds).  The firmware reports itself as the most current, so I will look into performing a factory reset and reconfiguration once Comcast has fixed the cable modem’s issues.  At that point, I will post a follow-up here to update on the situation.  Thank you for your help thus far!


It’s been reported before that disabling DNS Proxy might increase stability of the router. In addition to setting only 802.1n mode on BOTH networks, you might as well chang 2.4Ghz to 20Mhz instead of Auto (keep Auto for 5Ghz network though).

Thx, Serge.

I have the same issue with both my 2.4ghz and 5ghz wireless signals dropping. However, my problem only seems to happen once every 1.5 to 2 weeks. I can’t even find either wireless signals on my iPad, iPhone, iMac, or Dell laptop. So then the only solution is to completely turn off the router and reboot it. Is there any fix for this? I really am getting frustrated. I did try to put my 5ghz signal the N only but I have a couple devices that connect using G network on the 2.4ghz signal so I had to leave that one as is. Is there any way that maybe this routers DHCP IP Address connection up time has some from of maximum limit that causes issues. Maybe WD could develop an auto reboot feature during no actively (4am) or programmable. That might solve this issue people are having. Otherwise, I’ll be forced to return the router but it’s a shame cause I really like the router when it works.

 Flushing the DNS via ipconfig -flushdns solved the internet-connection-specific disconnects, meaning I don’t need to contact Comcast.  Concerning this new advice: the DNS Proxy wasn’t enabled, fortunately.  I set the 2.4Ghz band to only use 20Mhz, and so far it seems to be holding stable.  I will keep tabs on it and report back tomorrow if the problem resurfaces (after seeing if 802.11n only helps in such a case); if the problem does not re-emerge, then this seems to have been the solution I needed.

EDIT: Further testing has revealed that 1.) the 20Mhz switch did not fix the problem, and 2.) switching to 802.11n exclusively makes the problem considerably worse.

EDIT 2: Performing a ping test reveals that the router itself is no longer having issues after all.  The remaining issues appear to all be on Comcast’s end, as the DNS flush did not in fact resolve the connectivity issues completely.

It would seem that the LAN on this particular MyNet N900 Central has some serious issues.  When attempting to connect a cable between the router any any computer, it experiences nearly 50% packet loss from ping, most of them being “general failure” instead of “request timed out”.

EDIT: The problem has been resolved.  A hub device had a loopback connection on two of its ports that was causing artifiical network traffic.  Thanks to everyone who tried to help!

I just bought this router and am experiencing the same random interent disconnecting problem. Both wired and wireless are randomly disconnecting. On my PC, I noticed the internet connection is restored automatically after a while and sometimes it is not.

Could you explain “loopback connection on two of its ports that was causing artificial network traffic” ?

My firmware version is 1.07.16


Try the following:

  1. Firmware reset

  2. Disable DNS proxy

  3. If you have only -n devices - disable mixed mode on both WiFi.

  4. Put 2.4Ghz into 20Mhz channel width.

Thx, Serge

Thanks for reply.

I will try # 1, 2, 4 and report the result. I can’t do #3 because I have G device, maybe as a last resort.

I have had Linkys Routers in the last 10 years and only had to reset several times. I can’t believe WD makes this kind of product. Consumers complaining dropped internet are all over the internet. Only I read the so called experts reviews before buying this and missed all those complaints. I learned a lesson.

After spending useless times on the internet for this STUPID product, I am not sure whether there is a solution except returning it before 30 days. I hope your kind advice works. Thanks very much.


In the last 5 to 6 days, there was no internet drop on either wired or wireless. I didn’t do anything that was suggested here. The only things I did as I reccall was that I updated SmartWare and tried to reconnect from in “Network and Shareing Center” and sent some report to microsoft. I hope I found a solution.

Any comments from WD staff or experts? I would appreciate it. I would like to keep it if it is working. Thanks.

Greeatings pepole!

Hi I have the same problem. it connects off suddenly without Reason. I have also experienced dhcp is gone away from the the LAN side but works on the WLAN side.
just now cuple minutes ago i got no internet connetion on my win 7 ultimate ive just restarted the router wd now i cant log into it! Internet is back (if not in culdent post this.) but i cant login into the router! in sayes i got the wrong password? but ive never changed it! its the same ive used! allways! strange? my field of study is computer networks ive never seen a dhcp act this way! it seems the router maby get Full? I need to reset? Ive was looking over the OSI model to see on if ive missed Something but i cant figure this one out!


If it is the same as the N750 the password resets to the default when powered off/on instead of the password you have set.

Thanks i will try this :wink: