Mynet n900 central- internal drive not found, wireless network still works

I’ve had a mynet 900c for about a year now and have had no problems up til now. I have only used it as of late as a wireless shared storage at home, not hooked up to the internet. Recently in moving furniture I disconnected power to the device and upon reconnecting power I found that while my two computers could reconnect to the device, the shared storage was no longer available. I’ve got a bit less than a TB on the storage before this happened.

The device does not appear to have been reset- the admin password for the dashboard remains unchanged.

I was able to connect my external hd via usb to the device, map the network drive, and access files off the external hd. Both my computers access the router by either ethernet or wireless without a problem.

In WD quickview when I hover over the task bar icon it says “MyNet900c” under drive name, “N/A” under Used, and “OK” under temperature.

In WD smartware the program says that the device has “No writable WD Smartware partition found” I can’t seem to figure out what happened to the storage.

Any help would be appreciated.

Hello and welcome to the WD community.

Try to reset the unit and see if this makes the Storage appear again. This is really strange behaviour from the router. Press the reset button on the bottom of the unit for 4 to 6 seconds and check if it works properly again.

This link might help you out with the reset process:

Thanks for your response.  I considered resetting before posting here, my main hesitation was that I wasn’t sure if resetting it would wipe the hard drive.  Is that not the case?

Hi, actually it should not erase the drive inside the router at all. in order to erase the drive you would have to go to the storage section and then you can erase the data but a reset wont erase it, only the settings will be back to default.

1 Like

I followed the instructions to reset the router but it hasn’t solved the issue.  When the reset was done I went back into the dashboard, re ran “set up storage” and my computer is still not showing the device’s hard drive.   That includes through WD Quick View, through explorer, etc.

Anything else I can try?

Hi, on this case I recommend contacting support for further assistance on this matter: