MyNet N900 : a nightmare (at least for me)!

Hi everyone,

Recently, I got my WD N900 Router. What interested me were it’s 7 Gigabit Ethernet ports and the 2 USB ports. 

My purpose for this buy was following. 

I have a box that can contain up to 4 hard drive and that connects using a USB connection. So basically what I wanted to do was hooking this 4 drive bay to the MyNet to share the content of the 4 individual hard drives betwenn the 5 computers in my home and also be able to view the content from my universal Blu-Ray player that can access the network over Samba. 

Well, all of this failed ! 

First of all : I expected, as any other NAS or Router I have owned so far, that the hard drive that I hooked up to the N900 would show up in the list of network devices on my Mac. 

Well, it does not ! 

The only way I have to let those hard drives appear is to turn the N900 to an access point instead of a router, and to enter the SMB address of the N900 in my Mac to get access to the drives. 

Second of all : when the bay is connected, the N900 recognizes 2 drives. But if it shows the content of one of them, the second shows up with only 450Mb of free space (when there is 2Tb) and there’s no file showing up (although there are several files on the disk). For a recent devices, this is weird, considering that my old LaCie NAS mounts both disks withou t a problem and so does the Apple Airport Extremen that someone lend me. 

Third of all : if the disk finally show up if I use the “Connect to…” and enter the IP address manually, they do not show with their volume names. Only some weird “Samsung EDL-43549-39”… Not really simple to determine which disk is what ! 

Fourth of all : I do believe that WD has used some implementation of Samba of their own instead of the regular samba port. Why ? Because I was unable to access my shared hard drives from my Oppo BDP-105 Blu-Ray player. I can see the disks, but when I try to access their content, I am asked to enter a Login and Password. I can try to type whatever I want (from the standard “admin/password” to the self determined L/P ID’s that I decided to assign to the USB drives in the dashboard) I always get an “Unkown User or Password”. I had this exact same problem trying to share files from my Mac, and that was due to an implementation of SMB that wasn’t standard. So I guess this is the same problem here…

Fifth of all : I can work around the problem doing following. I hook up my 4 drives bay to my LaCie NAS. I then hook up the LaCie NAS into the ND900. And then my Blu-Ray player sees the LaCie and I can access the hard drives. But unfortunately, this does not work. If I try to play a Blu-Ray .iso, I get horrible frame drop outs and sound drops that make the movie unwatchable. As my BRD Player is only a 100Mbps network enabled one, I suspect there’s a problem in handling the mix of Gigabit devices and Fast Ethernet devices. Weird enough, doing the same thing using Apple’s AirPort Extreme works like a charm. the same dopouts I have experienced with my older Netgear CPL. 

Sixth of all : it is not possible to change the routeur’s IP address. Shre the option exists. But why on earth is WD offering an option that just disables all communication with the N900 ? I typed in the IP address I wanted to assign to the N900 : 192. 168.0.1 instead of The N900 rebooted and after it did, nothing works : it will not assign IP addresses over DHCP and it is impossible to get to the dashboard using the given IP address (and setting up the MAC IP address manually, of course !). 

So, after sepnding hours to even try to get this to work, I will give it up and stick to the Apple AirPort Extreme solution, and will add it an Ethernet Switch to get my 7 ports as on the N900. And I will use a USB Hub to replace the 2 USB ports of the N900. That works, even though it’s not as elegant as the N900 would have been :frowning:

All in all : a device that looks attractive, but that really does not fit my needs and is ABSOLUTELY NOT DESIGNED TO WORK WITH A MAC !  So MacUsers : pass on this ! 



Check page 62 of the manual to review the steps.

Hi Alucardx23,

Thanks for the help. 

Unfortunately that does not help. 

I am still prompted to enter a L/P to access the files from my Bly-Ray player to be able to stream them. 

And even if I said that I xant to share the files using a user account, and enter the values I’ve given for that user account on my Blu-Ray player, I still get an error message. 

This is why I think that WD has implemented their own version of SMB. Because on OsX, I get the exact smae problem… which is known to be caused by Apple’s own implementation of SMB and is solved by re-installing a genuine SMB software to bypass the one provided by OsX Mountain LIon :slight_smile: