MyNet 900 Wireless Broken

Well, it’s just 2 days past my one-year anniversary of owning this router, and the wireless function crapped out. The wireless LED remains on and the internet functions fine to my computer with a cable connection. But no wireless signal is being broadcast.

I’ve tried power-off-on, factory reset, reboot.  What else can I try?   (Yes, I have the current firmware.)

I’ve had other issues with this router, but at least the basic functions worked okay…until now.

Hi, have you tried pressing the reset button? If that doesn’t work try rolling back to the previous firmware. 

How to Install the Firmware Rollback:

Yes, as I said in my message, I did try reset.  Might try a rollback, but only as a last resort. Doesn’t seem likely that would help since it had been working for months with the current firmware.

Hi again, you can try doing the firmware rollback as a troubleshooting step, you can always update to the latest firmware again. 

If wifi light is on, it is being commanded on.  If settings show wifi enabled, it is enabled.  It all previous is true, your wifi chips are toast.

the problem is there are multiple seperate chips inside.  I doubt all failed randomly.   Have you recently experienced power outages orsurges? Or lighting strikes nearby or very stormy weather?  Any other electronics in house acting weird, not normal?