MyNet 900 no OpenDNS support?

OpenDNS doesn’t seem to work.  I did a bit of searching online, no solution.  A few places with people suggesting it just can’t be done on this router, which I find hard to believe on a router this expensive - if thats true this thing is going back to the store.

Anyway I just want to set up openDNS to filter adult sites:

WAN > Internet Setup

Primary DNS:  208.67.222.123

Secondary DNS:  208.67.220.123

This has always worked with my linksys as well as a netgear I had for a while, not sure what the problem is here.  I reset the rougter and computer just to be sure.  Still no good.

Any help would be great.

WAN / Internet Setup

Hey,

I am using OpenDns with no problems. The DNS servers I use are not the same as yours:

Primary DNS:  208.67.222.222

Secondary DNS:  208.67.220.220

Hope this helps.

Make sure your Public IP hasn’t changed. Otherwise you have to reconfigure your OpenDNS account.

You might think you’re using OpenDNS, but if you check ipconfig /all you’ll probably find that your using not only the OpenDNS servers but also your original IP’s DNS servers.  That negates the OpenDNS filtering–at least in my case.

I went through all kinds of trouble shooting with both OpenDNS and WD techs with no successful results.