MyCloudMirror Freezes When Transferring Numerous Files

I currently have a My Cloud Mirror with two 2TB drives in a mirror raid 1 configuration. I am running the current firmware (2.12.127). My Cloud Mirror is connected to a Windows 10 Pro OS computer via an ethernet cable. When I attempt to down load numerous picture files or large movie files periodically the Cloud device freezes. The only way out of the freeze is to power cycle the device by pulling the power plug. Being careful on the number of files I try to load at one time or the size of the files to load to the device will sometimes prevent the freeze from occurring. Is there a solution of this random freeze?

1 Like

This slow performance could occur when the unit is busy or under a load indexing content, performing backups or building thumbnails.

https://support-en.wd.com/app/answers/detail/a_id/3534

Thanks for your feed back. I will try the evaluate performance the next time this occurs. I have tried to get into the My Cloud Dashboard before when this occurs but the system appears to be hung up or frozen and I receive a windows message that the device is not available. I will have more specifics on the next post.

Yesterday I performed the process described @ [https://support-en.wd.com/app/answers/detail/a_id/3534 ]. This did not work. This morning I tried to remove two big folders of pictures. The first (45GB & 8,000 pics) Removed ok. I then tried to remove a second folder of pictures (~33GB & ~8,000 pics). The unit hung after a few minutes. It appears the unit was trying to determine what files needed to be removed. When it hung the unit would no longer communicate with the network. When I tried to bring up the Admin function I received a system message that said an error occurred while reconnecting the MolFamCloud device. I access the cloud device via a network drive assignment in Windows.

This afternoon I used the WD My Cloud application to upload files instead of the Windows Network device drive. I used version 1.07.17 to upload 7 zip files average size about 7 GB. The upload failed because the WD Cloud device froze or lost connection with the network. Noe of the folders were uploaded. Same device freeze symptoms.

I have same problem for quite some time. I’ve read somewhere, that it happened after firmware update. Recommandation was that you should’n update to that particular firmware. But even if I knew name, I don’t know, how to revert it (and nobody said, that it will fix the problem). Maybe setting to factory setting would solve it, but I’m affraid I’ll lose data beacause loosing access rights.