MyCloudEx2Ultra can't open Dashboard page

The device is working fine. I can access all my files.
But when i try to reach the Dashboard page, it just stays blank white.
Also, when I open mycloud on the phone, it says the nas is offline. But the photo upload seems to have worked, at least until 2 days ago
Have tried the following:

I’d rather not reset anything…
What to do?

Habe tried that aswell…

You’ll have to look it up but have you tried the soft reset? Just resets the IP/admin password. Wondering if that would help.

I’ve had it get stuck when trying to update the anti-virus and I couldn’t load the dashboard until I restarted the device.

Thanks for the advice.
That did unfortunately not work either.

Is ssh active on your device ?

So - - - spit balling here - - - -

Sounds to me like the IP of the NAS has changed. Any new PC or routers on the network?

Does the NAS show up on your router, or in Windows File Explorer?

Have you tried accessing using the ip address vs using the device name?