MyCloud won't Sleep after update! Help

I haven’t seen this problem for a long time (many updates ago), but unfortuneately - it’s back!  My device will not sleep anymore since I installed the latest update.  I have tried reboot, but no luck.  Any thoughts??? I also tried turning it off and then back on as well - no luck.  (with reboots of course)  Very annoying and I am so uncomfortable with having the drive spin all the time.  Someone PLEASE HELP!!! (if you can) Thanks in advance.

I had the same problem, constant wake ups. Unfortunatelly I had to roll back firmware to previous version as I had not found any sollution.

You guys are too impatient.

It’s a WHOLE NEW OPERATING SYSTEM called OS3.

And if you’ve update your windows or linux system, chances are something is going on in the background that you may not be aware of.  I suggest to upgrade to OS3, go to the bar, beach or whatever, take the wife and kids out for dinner, have a good nights sleep and check the next morning.

I have 2.6 TB of family photo’s videos and it took 72 hours before things came back to normal and the new OS3 is much faster than the previous version. Mobile app is more responsive than ever before.

Give it a shot!

Init0, I have no problem with indexing, the problem is that the drive goes to sleep and then after 5 seconds it wakes up again and does it all the time. IMHO If it was indexing the drive wouldn’t go to sleep

I have also one question, after i rolled back to previous firmware I cannot see new firmware anymore - check for update gives message that my fw is up to date :), is that normal ?

What method are you using to determine that the drive is going to sleep and then waking up in 5 seconds?

RAC

1 Like

I can hear that, I’ve also checked user.log file and there are a lot of wake-ups. I just want to know if other users have the same issue after FW upgrade.

Pretty much everyone has this issue: some notice, some don’t (and claim it’s all right with their MyClouds).
I really hoped WD would solve the issue or at least someone would come up with the idea why it happens but nope: it’s all guesses, lots of guseeses.

@ tzalewski: are you located in Poland, elsewhere?

@LardVader, yes Poland

I see that they changed the log entry for when the system puts the disk into standby.  Here is the new sleep.awk file.

Use this command to get the sleep times. cat /var/log/user.log|./sleep.awk.  This is the output from my system.

09 20 14:21:56 14:22:03 7 0:00:07
09 20 14:49:32 15:05:53 981 0:16:21
09 20 15:16:04 15:17:11 67 0:01:07
09 20 15:27:22 15:31:10 228 0:03:48
09 20 15:41:21 16:01:12 1191 0:19:51
09 20 16:11:23 21:39:11 19668 5:27:48
09 21 21:49:22 00:30:11 9649 2:40:49
09 21 00:40:22 03:00:11 8389 2:19:49
09 21 03:15:22 03:15:30 7 0:00:07
09 21 03:25:40 05:46:21 8441 2:20:41
09 21 05:56:32 08:01:11 7479 2:04:39
09 21 08:11:22 08:22:37 675 0:11:15
09 21 08:32:48 08:33:46 58 0:00:58
09 21 08:43:57 09:29:17 2720 0:45:20
09 21 09:39:28 09:56:12 1004 0:16:44

I must add that my system didn’t sleep after I upgraded to the new firmware until I made a few changes.   I did the

mount -o remount,noatime,nodiratime /dev/root /

I stopped the following scripts: S03atop,S20restsdkserverd,S85twonky,S85wdmcserverd,S86photodbmergerd,S92wdnotified,S95AutoMount and S96onbrdnetloccommd

I don’t know which of these processes is stopping sleep from happening.  I know that the S20restsdk-serverd was writting to the disk every minute or so.  Even after these changes its still not sleeping like it should.

RAC

sleep.awk

awk ’
NR==1 { a=substr($1,6,2); b=substr($1,9,2); c=substr($1,12,8) }
{if ($7 ~ /after/){
hh1=int($8/3600)
mm1=int(($8%3600)/60)
ss1=($8%3600)%60
Total = Total + $8
printf “%2s %2s %8s %8s %5d %2d:%02d:%02d\n”,substr($1,6,2),substr($1,9,2) ,substr($11,0,9),substr($1,12,8),$8 ,hh1,mm1,ss1}}
END {
hh1=int(Total/3600)
mm1=mm1=int(($8%3600)/60)
ss1=($8%3600)%60
printf “Total Sleep Time: %2d:%02d:%02d\n” ,hh1,mm1,ss1
start= a “/” b “/2015 " c
end= substr($1,6,2) “/” substr($1,9,2) “/2015 " substr($1,12,8)
$1=start
#print start " " end
cmd=“date --date=””$1"” +%s"
#print cmd
cmd|getline st
printf “Start %s\n” ,st
$1=end
cmd=“date --date=”"$1"" +%s"
cmd|getline end
#print cmd
printf “End %s\n” ,end
Total=end-st
hh1=int(Total/3600)
mm1=mm1=int((Total%3600)/60)
ss1=(Total%3600)%60
printf “Total Up Time: %2d:%02d:%02d\n” ,hh1,mm1,ss1
 }’

Hi. I have a same problem. A few days ago I bought a cloud. Refreshed. Then he did not want to sleep. I’ve done everything I’ve read all in the forums. Until the networks settings turned off the DHCP and static IP address setted. Only the IP address and subnet mask + gateway!! The DNS was left blank. Then it began operating in sleep mode! I wish you a nice day. ( Sorry for my english) :slight_smile:

The sleep mode is a common complaint with many threads discussing it. One needs to monitor the My Cloud over time to see if the unit actually goes to sleep rather than what it does for many; goes to sleep for 7-10 minutes then wakes up. The My Cloud should go to sleep after roughly 10 minutes of inactivity, the problem is that after it goes to sleep it will often wake up every 7 to 8 minutes due to services being run in the background.

A few previous threads on the sleep issue:

https://community.wd.com/t/sleep-awk-script/145039

https://community.wd.com/t/mycloud-does-not-go-to-sleep-standby-perhaps-the-solution/158591

https://community.wd.com/t/this-resolved-my-cloud-sleep-mode-issue/157059

https://community.wd.com/t/wd-my-cloud-randomly-wakes-up-the-drive-when-drive-sleep-is-enabled/152748