MyCloud won't connect

Haven’t used mycloud in a while, and tried to connect today. It initially connected, but was very slow - using ehternet connection to Macbook Pro. After a while it would keep freezing up. Did a little homework and WD suggests updating firmware. My question is how can I do this if the device won’t connect? Light is steady blue, and I have full internet connectivity, but when I go to mycloud it says device offline.

Have you tried opening the My Cloud Dashboard? Unless you’ve change the name of the My Cloud you can reach it at http://wdmycloud.local using a web browser on your Mac computer to access the My Cloud if your connected to the same local network the My Cloud is located on.

Yes, tried that too. Says won’t connect. I had rebooted my router and was able to connect to files through a program called Path Finder. If I use Mac finder I can connect but then can’t open any folders or files.

For the past hour I have been able to open and delete files through Path Finder, but still can’t connect through web or through mycloud.local to see about updating firmware. Also tried to connect through desktop app but that tells me I can’t connect either. So I can access my files through Path Finder but for virtually everything else it tells me I can’t connect.

I have similar problem with WD My Cloud 4 TB.

  1. After hard reset it works a couple of hours
  2. No SSH connect possible: access denied - no matter, root, admin, sshd etc.
  3. The firmware is latest 04.*
  4. The performance of dashboard reduces dramatically
  5. After 2-3 hrs no dashboard connection possible
  6. The shares are visible and work good enough
  7. the only way to get it working again is turn the power off and on
    I’m tired of this device

If you keep resetting or removing the power, you will restart the media and file indexing and thumbnailing processes. These take a lot of CPU, and can take a long time to run.

The MyCloud is intended to be an always on networked file and media server.

Try leaving it alone for a day or so to do its stuff, and then see if it responds better.

Make sure your router hasn’t given your MyCloud a new IP address; check using your router’s admin interface.

Well, after 48 hrs the Web dashboard is still unavailable :frowning:

I am having very similar issues! After a few hrs, cannot access dashboard. The drive is working but…

  1. Smartware is not backing anything up!
  2. MyCloud on IPAD is not backing up pictures!
  3. I can only access my shares via my iphone or the MyCloud app! (I cant map the shares to my computer!
    This is really frustrating…anyone have any answers?

Back again and unable to connect to MyCloud. Light on device is solid blue, but it doesn’t show up on my Mac network at all. If I go into it shows the device offline and refreshing does not help. I don’t want to restart because as mentioned here that will just cause reindexing. I checked my router settings and the IP address has not changed. How can I update the firmware?

Have you solved? as I’m today in the same situation. did the 4 seconds reset, after the 40 seconds power off and power on but it is not allowing me to connect to do the software update. :frowning:

It’s not a firmware problem. I expect it is the problem everyone has been having, due to WD’s servers having trouble.

I notice the WD announcements about this have been removed, but there are plenty of recent and ongoing threads about the fallout of this service outage.

As for how to upgrade the firmware: read the User Manual.

I don’t know that I “solved” the problem. I did unplug the drive and waited 30 seconds and plugged it back in and let it reset itself. I cam back hours later after work and was able to connect, at which point I was then also able to update the firmware. The “read the manual” comment was extremely helpful - I just can’t find anywhere in the manual that it will tell you how to update anything if you can’t connect to the drive using any of the methods available - desktop software or through a browser.

Did you find the reset instructions in the manual?

You appeared to be having a problem with and thought it was a firware problem; that’s what I was trying to address.
Glad you got it sorted with IT response #1: “have you tried turning it off and on again?”

A post was split to a new topic: Removed post