MyCloud with Airport Extreme, extreme slow

Hi guys,

Anybody knows how speed up MyCloud? It’s very, very slow in my macbook, in my ipad is a little bit faster.


Hello, can you tell what transfer rates are you getting and are you doing remote access or local? 

I’m having the same problem.

Macbook, Verizon Fios Wireless router.  The MyCloud is hooked right up to the Verizon router, (they are gb ports).

Copying over any kind of file, small, large is REALLY slow.

Estimated times for 40 gigs is 17 hours.

I’m dragging the files into the finder window.

It doesn’t matter if I plug the computer in hard wired or wireless.

The mycloud settings has it set as a static ip.

Should I be returning this?

Thanks for your help everyone!



I’m using a Macbook Pro 2.5 Core i7 8GB, near my router (Airport Express 5Ghz).

Transfering 150 GB is about 20 hours, with max data sent 2.8 MB.

The biggest problem is when I try connect it to see my things. It takes 1-5 minutes to mount it on my desktop.

I’ve already tried turn off and on public, media share, etc… without success.


If you’re using Mac OS, make sure you’re connecting for SMB instead of AFP

I’m using Maverick.

How do I do this? In Airport utility or in settings of my cloud?

 Didn’t looks like mycloud have a opened port for smb:


MyCloud already uses the SMB2 protocol, so you would be doing this on your Macbook.  On the Finder menu, click GO > CONNECT TO SERVER…

type in the server address:  smb://

where is the ip of the My Cloud


In this way it has the same speed…

Why do not mycloud have the same speed of my hd attached into wdtv (plugged into same airport extreme)?

Is it a product limitation?

My best