MyCloud White Light Constant, Unable to Ping, Dead?

I know I’m risking getting sent a link and scoffed at, but that’s ok. I see lots of similar issues but none that seem to apply to me.

First off I’ve got a single bay 3TB drive that was working fine for the past few years and then just suddenly wouldn’t give me that sweet blue light. I just got a new Asus Zen WiFi AX mesh setup and thought that must be it. Did some digging and tried the resets. Tried my old router. Tried directly to computer. Nada.

I’m unable to set the DHCP outside the range due to unable to see the device as connected. Can’t ping at all from the computer. I ran the router system log and found this:

Dec 1 15:24:17 kernel: eth2 (Ext switch port: 1) (Logical Port: 9) (phyId: 1) Link Up at 1000 mbps full duplex
Dec 1 15:24:23 kernel: eth2 (Ext switch port: 1) (Logical Port: 9) (phyId: 1) Link DOWN.
Dec 1 15:24:27 kernel: eth2 (Ext switch port: 1) (Logical Port: 9) (phyId: 1) Link Up at 1000 mbps full duplex

Matches what i see on the old router. Shows a connection for a few seconds, goes blank, comes back over and over. If i stare at the MyCloud for a long time the white light blinks off for a second then comes back on and just sits there.

Physically the drive feels like it’s only occasionally bumping during this whole process.

I’m guessing it’s dead and i’ll be asking about data recovery. In the meantime I can’t wait to hear your thoughts.

@BeezyHeezy For a 1st generation WD MY CLOUD the blue LED does burn out, but they usually keep working. Mine is working.

Here is a link for the User Manual. Look at Chapter 2, LEDs.

If doing a reset on a single bay/single drive My Cloud make sure to do it as WD suggests.

https://support-en.wd.com/app/answers/detail/a_id/24022

If one has previously set a Static IP address within the My Cloud Dashboard, changing to a new router may cause access issues if the My Cloud is on a seperate IP address range. A 40 second reset should reset the My Cloud back to default of asking the router for the IP address.

Do not connect the My Cloud to a Mesh node, always connect it directly to the main router’s network ports. Check the user manual for the Asus mesh router system to see if there are any special setting that could be interfearing with the My Cloud or similar NAS boxes. Settings like “client isolation”, separate networks (main, guest, etc.), network port isolation, etc.

As previous poster indicated, the blue led on first gen single bay My Cloud units can burn out but the device will still function. Plenty of other discussions on changing the LED color from blue to another color like green. An example discussion on changing the LED to green.

If the My Cloud unit has indeed died one can extract the My Cloud hard drive from it’s enclosure (called “shucking”) and connect the hard drive to a computer using either a docking station, USB to SATA adapter, or a spare SATA port. Then using either Linux (or a Linux boot disc/USB flash drive) or a Windows Linux driver one can attempt to access the data partion (typically the largest partition which is formatted for EXT4) and copy their data to another hard drive or location. If using Windows one must use a third party Linux driver. Windows will not access or read the My Cloud extracted drive without a third party Linux driver.

I saw that elsewhere too and hoped it was a burned up LED. Mine doesn’t flash. it comes on solid and stays on only blinking once every handful of minutes.

Thanks. I’ll reboot the main modem / router and try again. I hadn’t set a static IP so i’ll do a fresh 40 second rest. If that doesn’t work I’ll be having oysters! (Never thought I’d be able to make a shucking joke in a tech forum.)

Thanks!