MyCloud total size of 0 bytes and 0 bytes free space - what the heck happened?

For the past few months I’ve been noticing that my 4 TB MyCloud (Personal Cloud Storage) drive was getting surprisingly full. I didn’t investigate immediately, simply deleted or moved a bunch of data off the drive.
Total data usage on this 4TB drive is about 0.8 TB, consisting only of backups; no media is stored here.
However, a few days ago I was notified that my drive only had 120 GB left. In other words, something else was eating about 3 TB of drive space. Several discussions on this forum about “ghost data” didn’t explain much, but the common theme was to do the 40 second reset and update the firmware.
I updated the firmware and did the 40-second reset. I reset several times, because the light just wouldn’t stop flashing and turn to blue. The WD website says it should be about 15 minutes to reset.

The result: I have a dead brick attached to my network that has a total size of 0 bytes and 0 bytes free space remaining: everything is gone! I can’t view anything, either in Explorer or in WD Access.

Unless there is some magic that can bring this thing back to life, I’m ready to get rid of this brick, which begs the question: is there some way I can ensure that no one can recover the data on this drive?

Can anybody shed some light on this? Thanks!

Are you using WD Sync? If so that is most likely the cause of a mysteriously full My Cloud. WD Sync keeps a “history” of files that are synced so they can be recovered if deleted. These are stored in a hidden directory on the My Cloud.

If you can access the My Cloud Dashboard, do so and enable SSH under the Dashboard Settings. Then one can access the My Cloud at the root/firmware level to see if the user files (Shares) still exist and one can remove the WD Sync hidden history files to free up space. The following post explains how one user recovered data hogged by WD Sync on the My Cloud.

If one reset the My Cloud via the reset button on the back of the unit, that will not remove user data files. However if one performs Quick Restore or a Full Restore through the My Cloud Dashboard, that WILL delete user data.

Thanks for responding, but no, I do not use WD Sync and no, I cannot access the Dashboard. All I get is the WD logo and “My Cloud”.
Without the dashboard there isn’t much I can do, it seems.

Because the reset supposedly doesn’t delete data, that’s why I’m worried that the data may still be accessible by some persistent geek and I’d like to properly destroy this drive and its data. How can I do that?

Couple of suggestions. Try a different web browser if you haven’t already. Or try disabling any ad/script blockers on the web browser.

If you previously enabled SSH you can use Putty or WinSCP (if using Windows) to access the My Cloud at the root/firmware level.

One can destroy the My Cloud hard drive like any other hard drive. Remove the drive from the enclosure and physically destroy the hard drive itself. For example disassemble the hard drive and its components and smash them with a hammer until they are unrecognizable bits of plastic and metal.

Or one can remove the My Cloud hard drive and attach it to another computer and run a drive erasing program on it. Or one can try to fix the problem with the firmware by “unbricking” the drive. Use the forum search feature to find many past discussions on how to unbrick a My Cloud.

If you can’t get to the dashboard. How do you know it is 0TB for inuse and free space?

@rac8006:
from the WD taskbar icon:
WD Access > WDMycloud > Properties

That is most likely because the WD taskbar can’t talk to the My Cloud.
Can you ping the My Cloud? If you were to run the wakeonlan program
does it show up as one of the devices that you can wakeup? I understand that wakeonan does not work on the My Cloud Gen1 or Gen2. It is just a program that will scan the network and tell you what devices are visible.
https://www.nirsoft.net/utils/wake_on_lan.html
You should also try arp -a from the command prompt.

update: after trying various suggestions - thanks all - last night I was ready to dig into my toolbox for a sledge hammer, but figured I’d give the 40-s reset one more try. Lo and behold, it came back to life, data and all. I’m currently into hour 18 (and counting) of a complete Factory Reset and plan to resell this thing if anyone wants it. Ever since I bought this drive 3 years ago, it’s been nothing but headaches. I’m going back to an old-fashioned external drive.

Thanks for all your help, folks!

update some more: 95 hrs into the factory restore and still going . . .
I’m beginning to wonder if it’s doing anything, or is the clock the only thing that’s moving?
Speaking of that clock, it only counts up to 24 hrs, then starts again at zero, showing 21:27:01 right now into the fourth cycle.
Should I keep it going for another 24 hrs? Or give up and bring out the sledge hammer?

If you did the restore that securely wipes the My Cloud, it could take a number of days to securely wipe a 4TB My Cloud due to how the secure wipe process works (typically writing zeros to each sector/byte).