MyCloud Sync Issues

#1

Over the last few months I’ve been observing issues with connecting to my device via MyCloud Sync. I’ve been seeing error messages connecting to device1234567-12345678.wd2go.com (redacted my unique device ID). The devices connecting to it have functioned in the past without issues and now I am unable to connect at all. I am using google’s DNS as suggested on the support page. Furthermore I am unable to preform a Domain Name Resolution Check on: device1234567-12345678.wd2go.com as described in this guide on multiple networks and at different sites.

http://wdc.custhelp.com/app/answers/detail/a_id/18619/~/troubleshooting-my-cloud-domain-name-resolution-(dns)-issues

I am starting to believe this may be a problem on WD’s side.

Anyone else observing these problems? Please advise.

#2

@adamho What is it that you are trying to do? Are you able to connect using files.mycloud.com .

Do you use WD Sync? What WD Device do you own?

#3

I am trying to set up WD sync but encounter an error stating “the remote name could not be resolved.” I own the original MyCloud (not home). I am unable to connect via that link but am able to access my files with the app.

#4

@adamho Did you place sync on the devices you want it on? Once on those devices it should show on the Dashboard under Cloud Access>Cloud Devices for (Your Name), and instead of WD My Cloud it would show as WD Sync. If it shows as connected then it should be working.

Do you have it showing in the Taskbar, bottom right of screen. See image below (WD), this was taken while it was syncing files that’s why the white line is under the icon.

WDMyCloudSyncsetup

I just deleted it on my computers because it seemed to be causing problems with my folders.

#5

I am having the same issue. I had to re-locate my MyCloud mirror. I went through the steps again on this network making sure my router was pnp. The remote backups from another location to this location are failing. When I try to do one manually, at first it just goes forever when I try to browse the destination to set the location. Then when I put the destination IP address in manually, it gets the RSYNC error. I found a years old article that said make sure port forwarding is set up on the router. I found that documentation for my router and made sure the port forwarding was set up. Now I get the RSYNC error.

#6

Hi, sorry for the late reply. I do have it on my devices I am seeing WD sync but am seeing this screen when setting up the NAS.

#7

Okay, I resolved my issue and the same might apply to you. I had a similar experience when I first set it up.

When you go into the settings on your MyCloud device and you set up the Network of the remote backup server, when you follow the instructions it says to set up both Remote Backup as well as SSH. You see those, right, at the bottom of your Network settings? If you did it on another router and now have a new router, delete those and do it over again because I think it updates the router through PnP. Don’t mess with the default port numbers.

But, twice now, I have found that is not enough. You have got to find those settings on the router where port forwarding is set up… I had to search the forums for my Nighthawk router and find how to do it, plus read the tiny manual (which wasn’t as much help as the forums). I did eventually find where to set up the port forwarding
Remote Server 873
SSH 22
Now, when I attempt the backup, it can find my backup server instead of getting that error message you are getting. Also, make sure you can see it from the WD files logon. That’s basic. If you cannot see that server from there, it is not set up right. I also use the App on my phone. But, both of those could see the remote server without those changes to my router. It took those changes for the backup to see it.

#8

Got it! Thank you for your help, that solved the issue for me. Took me a few days to get to it as I’ve been working offsite.