MyCloud switches to 100mbit on its own


I’ve been using the MyCloud 4TB for a while, and recently decided to wipe everything and start again.
Main reason: Wd smart ware and we sync just stopped working, so I switched to a third party software.

Thing is: naturally I’m transferring everything from scratch, so it’s a lot of data.
I’ve experienced very slow transfer speeds, and checked the leds on the back of the device and saw that it was orange instead of green, meaning the device decided it’s better of using 100mbit instead of gigabit like it should.
My solution that fixed that? Disconnected the network cable and connected again - now leds are green and I’m having ok transfer speeds.
I put the transfer in the background and go to sleep, and when I wake up the device is again in 100mbit mode!
The router was on, didn’t restart.

Anyone else experienced that issue?
Any solution to it?

Check if you have another device on your network that may be 10/100Mbit. If you are not sure, you can remove all the devices from your network and connect them one by one until the problem starts again.

I had a lutron bridge device that control my lutron lights at my house and it slowed the whole network down.

I have two devices connected on my wired network. My computer and the WD cloud. The computer always stays at 1gig

my only other guess would be the cable. Try a new Cat 6 cable?

I switched the cable today, but I’m sure it’s not the problem, because when I unplug and plug again it connects at 1gig

True that unplugging and plugging it connects back to 1GB, but that might just be indicative that the connection is dirty and fades over time, or possibly there is noise on the line.

Sounds to me like there is data error, handshake errors that the device is resetting the connection rate down to 100.

Are you sure that your PC is not the culprit? Are you actually getting gigabit speeds at the initial start of a file copy? like 10 seconds for 800MB? or perhaps as soon as you connect, the PC may be at 100mb and is taking down the network speed of which the WD cloud is detecting and steps down to 100mb.

Even though the Cloud changes to yellow doesn’t mean the cloud is at fault. Something is telling your Cloud that the network speed max is 100mb and it could be your router, cable or even your PC since it is the only other device on the network.

Try reseting your router. Power down everything and start up your router first, then your cloud, then restart your PC. Try other PCs? try no pc and leave it on overnight to see if the light goes yellow.

All my best guesses… it is up to you now… good luck… but do tell us what you find… if any…

and if you give up… go buy a new cable and try it… you never know…

Until now I used the cloud’s cable and now switched to a new one.
I get hours of gigabit transfer rate. I can see it when I copy files I’m getting 60-75 MBytes per second (not bits).
I had the cloud on the entire morning copying files on that speeds but when I checked just now the light is orange again and the speeds are down.

I tried restarting the router AND the cloud but the situation only fixes itself when I unplug and replug.
I bet that if I pull out the power cord it will also fix the situation. Maybe the cloud restart is just the interface restarting rather than the whole kernel. Not sure about that.

Meanwhile, my computer who has an uptime of weeks is still at 1gig connection. Always.
Something is messed up about this device and I can’t figure it out :sob:

try a new router :slight_smile: or a smart switch between your computer and the cloud.

Wow ok, thanks I guess.
This has to be one of the most incompetent pieces of hardware I’ve ever used.
BTW even after changing the cable, I woke up today and found out that the wd cloud was on 100bit mode again.

I shouldn’t have to switch a router just because a device can’t manage to stay connected on a specific settings on a network.
It’s not like it doesn’t connect to 1gig from the start. It does. But can’t keep it for more than a day.

Extremely disappointing.

Changing the router is just to test to make sure that it isn’t the problem itself. It could be the router that is making the cloud go into a 100mbit mode. Also make sure you try plugging into a different ethernet plug then the one you have.

1 Like

The MyCloud won’t change rate ‘on its own’. Link rate selection is a process negotiated by both ends of a link. There’s a problem with the link somewhere; it could be the MyCloud. It could be the router. It could be the cable. You need to find out which.

From my experience with WD My Cloud Gen1, I tried 3-different routers and several different cables to fix the low speed connection between router and My Cloud, but all failed.
Solution : I bought an used My Cloud board. And, it solves the problem with the same router & cable.
I still have the broken(?) board. And when I try it again, it still connects to my router with low speed, even 10Mbps.

I guess, that there is some problem with My Cloud board itself.
I’m sorry for not giving you the solution.

Thank you for your replay everyone…
I am very sorry but I don’t need to go and buy another router because the device can’t manage to handshake it’s way into 1gig connection.
It’s not the only device connected to my router. My computer is also connected and I’ve never, ever, had a problem like it.

It makes me sad to know that other people are experiencing it, and that WD isn’t doing much in order to fix the issue.

If the device is able to connect in 1gig in the first place - it should be able to keep that connection!
It’s not like it can’t connect at 1gig at all, it can! And I can use it for hours of transfer, using many, many GB of information. But at some point the device just goes “screw you” and lowers itself to 100mb.

Is there a way, and way, to change this preference for the device? to “force” it to connect only on 1gig connection? I know there’s a way to do it on regular computers but is this possible to do it on this one as well?

Thank you all for your replies

@SHACHAR_ADAR, remember that all of us are customers also so repeating your complaint about the cloud falls on deaf ears. There are no WD support people here except for @Bill_S but he doesn’t really count because he isn’t here that often either.

You are not buying a router to fix a cloud problem. You are not buying a cable to fix a cloud problem. You are buying a router to check if it is a problem between the router and your cloud. You are buying a cable to check if it is a cable problem between your cloud and router. It could also be a problem with your PC even though it says it is at 1GB, it may be trying to negotiate a lower speed because it is getting errors between your cloud and your PC.

Somewhere along your network PC=>Router=>cloud is a device that is negotiating a speed of 100mb with your Cloud.

You can replace (temporarily) each device to see who is causing the problem, or you can just keep posting about how unfair it is.

There is known modem/routers that do have problems with the WD Clouds (I forgot which? AT&T?) and the solution is to add a switch between the modem/router and the Cloud.

On the other hand It could be a problem with the cloud and you probably could have it sent in to WD to get it replaced with another refurbish cloud.


edit: @SHACHAR_ADAR, here read this …

1 Like

That’s not necessarily true.

If a link drops down to a lower rate, it is because the link devices are detecting high error rates over the link. This may be an intermittent problem that may be caused by conducted or radiated interference near the equipment, or a poor cable, or poor connection.

It is also possible that there is an electronic fault in either your MyCloud, or your router; none of us are trying to say the MyCloud is not under suspicion; devices fail; that’s a fact of life. How old is your MyCloud?. What we are trying to do is help you diagnose where the fault actually lies. The only way to do this without access to a network analyser is to swap out each of the possible faulty components. Try using one of the other router ports. Just because one router port is working correctly, it does not mean that all router ports are working correctly; they have individual electrical connections. Try using a different cable. Try using a different router, or inserting an ethernet switch.

1 Like

As mentioned above there is a known issue with certain routers and the My Cloud that can cause strange issues. Often it manifests as the My Cloud being unable to obtain a solid connection from the affected routers. You may want to see if you have one of the affected routers mentioned in the following WD Knowledgebase:

1 Like