MYCloud stops responding after attaching MyBook Essential

With the addition of a 3T MyCloud to my home network, I decided to move my WD 3T USB drive to the My Cloud with the intent of setting up some physical redundancy for backup.

When the MyBook is attached, it is visible under as a share under the MyCloud. However within a few minutes, the MyCloud becomes completely unresponsive to anything but a ping… There is a lot of audible activity (thrashing) on the MyBook, but appears to be little on the MyBook.

I let this go for a few hours with no response. detaching the MyBook and power cycling the MyCloud returned activity to normal.

Any Thoughts?

If the MB and MC are updated, you tried formatting the MB to clean it just in case and also disabled the sleep timer and encryption and still have that problem then I’d call WD.

@ GaryB139,

I have started with a clean freshly formatted USB 3.0 HDD and I did notice if you have stuff on it what was copied before, it does keep rattling the WDMC as well the USB HDD. I think it is best to keep the USB 3.0 HDD only on the WDMC and only take it off when the WDMC has given up the ghost and then you can put it on your computer if you want to take off your files do not write anything on the USB HDD from any computer USB ports. That is when you are using Safepoint for as backup. Perhaps there is a different way of writing and copying files if you use Safepoint ? If you want to take off the USB HDD and then write from different computers it might not be happy when you put it back on the WDMC. This is only a guess, because I have not tried this out. I only tried out when the USB HDD was backed up from my computer with USB and then put on the WDMC it was rattling perhaps same like yours and it was going nowhere. So my guess is keep the USB HDD only for the WDMC and let it only write on there. So far mine is doing well, after I had a ton of problems, it seems it has coughed out all its “demons” so far after updating to Hopefully. It has been only a week now. So now up to the next weeks, months, years of faithful working  as my old trusty LaCie Edmini does  ;-)

Here is some additional information. When I connect my 2T Seagate USB 2.0 device to the MyCloud, it continues to operate just fine and the Seagate share is visible. I also tried a 16G Flashdrive, which also operated correctly.


The MyBook and MyCloud both have the latest firmware. Seeing that the WDMyBook operated corectly on USB 2.0 and 3.0 ports on several different computers, I am hesitant to implicate it as the culprit. There is no encryption set up on it either, as such reformatting it should be uncecesary.


I may take my USB2.0 hub and put it in the path between the mybook and mycloud to force it to downspeed.


Anyone else try USB 2.0 vs 3.0 with mycloud?

Thank you both

Well I added a USB 2.0 hub in the path and the MyBook appears to work just fine.

At this point I think it’s up to WD to address the issue.

I have the same problem as yours.  My new 3TB WDMyCloud gets funny as soon as I connect my portable USB3 WD Passport drive into it : the ssh CLI is slooooow or not responsive at all, it goes offline, the drive is not accessible anymore from the Pc, the WD My Cloud app cannot connect to it, etc.  Things get back to normal as soon as I disconnect the USB drive and power cycle.

I hope for a solution soon otherwise will have to return the item.

I haven’t heard back from WD Support yet, but have continued to play around on my own. There were 2 WD backups from one of my computers on it, so for giggles, I went to delete them. This was problematic as some of the files in the archive had long file names  and I was unable to delete these from the WD MyBook using the windows file manager or command line.

((BTW, the computer I had the MyBook Attached to at that time had a USB 3.0 interface, I didn’t tryto delete them with a USB 2.0 computer ))

This forced me to copy the remaining (important) data to another device, reformat the MyBook, and restore the data (no long file name). I re-attached the MyBook to the MyCloud w/o the USB2 Hub and the combination has been working fine.

I’m not sure if this has something to do wth the WD archive or long file names  nor how the USB 3.0 factors in.

If WD ever responds I will see what they have to say and post back to the forum.

But as much as I hate to reccomend it without a complete root cause analysis, I would suggest copying your data somewhere else, reformatting the drive and see what happens.

@ Rejdrouin,

Are there any pre files and data on the the USB WD Passport ? And if you do and do you have  Media Scan settings to ON on the shares as well in Dashboard ? Turn them all to OFF and then copy and paste to the Mc Cloud. Then later turn them on again and let it do the scan and don’t touch the MyCloud for a while until that is finished. Then start copying again. When the Media Scans are all on, it feel it chokes the MyCloud when you put a External HDD with pre files and data on it. I had the same. I just started with a clean External HDD and did the above. It seems to be working. :wink:

Im not sure if this is relevant. My local electronics store told me I could not connect an Elements 3TB HDD to My Cloud as it was a mains powered unit and only portable USB drives powered from the Cloud would work. This sounds crazy to me can anybody please confirm if this is true, or could this explain why some are having issues by doing this.