MyCloud Startup/Shutdown using an iPad?

Hi, I have just purchased a 3TB WD MyCloud drive. Everything working fine, but I was just wondering if there is a way to remotely start it up and shut it down using an iPad app? I know it can be done using the dashboard software on my Windows pc, but I very rarely use this and don’t want to have to boot my laptop up every time I want to shut my NAS down. Any help or advice would be appreciated. Thanks.

No, where startup is concerned you need to physically unplug and plug the power cord from the NAS every time you want to power it up again. As far as shutting down is concerned you can use safari on you iPad to access the dashboard and do so. However, I think the iPad app might allow remote shutdown but don’t quote me on that as I’m not 100% sure.

Why do you want to do this shut down/startup? It is really not necessary and, in the log run, probably harmful to the WDMyCloud. These devices are built to run 24/7 with a small likelihood of failure. Basically, most devices suffer their most stress starting from a cold temp, not running at nominal temperatures 24/7.


+1, leave it on 24x7. It is design to run non-stop

If by any chance you still want to really shut it down, well, use any browser on anything (phone, tablet, pc).
The other option is CLI, but you will need a ssh connection. This can be done via an app from anywhere (phone, tablet, pc).

CLI Syntax look here:

Thanks for the responses, It’s just an obsessive energy saving thing I’ve got going on! I guess I’ll just leave it on 24/7. Cheers.

Check the power usage on the brick - it’s minimal, 18 watts.


There is NO way to remote start at this time other than reapplying power to the unit. The My Cloud (at least first generation devices) DO NOT support Wake-On-Lan which could potentially be used to power on or wake up a network device who’s network port has that feature/option.

See Shabuboy’s Safe Shutdown link. In that thread there is discussion on how to shutdown the My Cloud via SSH. I do so from my Android phone using an app called SSH Buttoenter link description heren. I’m sure there is a similar app for iThing devices.

While the directions (from the Safe shutdown thread) below are for using Plink one can issue the commands from any SSH emulator provided they use their My Cloud’s IP address ( the IP addresses used below are an example). The command starts after the IP address below.

Shutdown and power off:
plink.exe -ssh -l root -pw welc0me /sbin/shutdown -h -P now

Shutdown only:
plink.exe -ssh -l root -pw welc0me /sbin/shutdown -r now

Power off only:
plink.exe -ssh -l root -pw welc0me

plink.exe -ssh -l root -pw welc0me

@Bennor - The multi-bay My Cloud units have recently been given this feature - while it won’t help @Mark_Heardman, hopefully (I don’t know what our plans are for future devices) the feature will be popular enough that future single bay products will include it as well.

The issue and problem is that while you can put the device into hibernate or shut it down, there is no way to power the unit on (at least the My Cloud devices) without removing and reapplying power.

The link you provided for the multi-bay My Cloud units would appear to have the same problem. How to power it back on once in hibernation or shut down without removing and reapplying power.

Edit: I suppose one could drop some more money and use a “smart outlet” to turn off, then turn on power to the My Cloud.

From the article:

Wake On LAN enables users with access to the My Cloud device to wake it up remotely while the device is Hibernating.

I haven’t updated mine yet, but I did have this article vetted pretty thoroughly before I published it. Have you tried with today’s firmware?

Ah missed that bit. But how would that work if one actually shuts down the unit, would the wake on lan power the unit up or does one still how to cycle the power or use a smart outlet to control the power?

The issue becomes can the base single drive My Cloud units support wake on lan? When one checks the network hardware (via Linux command) the single drive My Cloud units do not indicate wake on lan support. My understanding is that either the motherboard or network port firmware has to have wake on lan support. How would such support be enabled if is not already supported by the My Cloud motherboard or networking port firmware?

Edit: No I haven’t checked the recently released firmware on the single bay my cloud units for wake on lan support. Will check when I have a free moment.

A sudo ethtool eth0 and sudo ethtool -i eth0 from a v04.04.02-105 My Cloud appear to indicate there is no Wake-on-Lan support on the network hardware.

sudo ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: external
        Auto-negotiation: on
        Current message level: 0x00000036 (54)
                               probe link ifdown ifup
        Link detected: yes

sudo ethtool -i eth0
driver: c2000-geth
version: 1.0
firmware-version: N/A
bus-info: N/A
supports-statistics: yes
supports-test: no
supports-eeprom-access: no
supports-register-dump: yes
supports-priv-flags: no

As I mentioned, this does not apply to the single bay’s and will not resolve Mark Heardman’s issue. I included it just in case someone came across this in a search etc. who had a different model.

I included the further information on the ethtool output showing no wake on lan with v04.04.02-105 because of your statement; “Have you tried with today’s firmware?”.

Yeah I put that together after I posted… For some reason I thought you had a multi-bay as well.

Wake on Lan is a standard, so I’m assuming (yes I know how dangerous that can be!) it works the same as on any other computer. I’ll ask someone tommorow and get back to you once I can say that for sure.

WoL has been around for desktops for quite some time and allows you to turn your computer on from hibernation remotely without the use of a remote outlet.

Just to follow up on this, I asked for a KB to be drafted to explain how to wake the unit back up. As a short answer, WD Quick View is the only supported method of waking the unit up.

I’ll post again once the KB is up.