Mycloud started failing, after reset I don't see files

Hello, i have a situation with mycloud. IT started to fail a couple of weeks ago. I have it mapped in my iMac and have access but sometimes in the app on iPhone I don’t see my files or folders. Then when I was mapped, tried to transfer a big files to mycloud, started transferring and after a while, I got error message. I contacted support from WD and after performing some “test”, he recommended to reset settings (on dashboard), “only system”. so I did it. After reset, I was asked for username and password for dashboard. I enter dashboard and I don’t see any files or users. I got “0 mb capacity”. 0 movies, 0 photos, 0 music, etc. I cannot map it anymore (always got error messages) Only access to my dashboard

I contacted again support and now he said “its a problem with disc and suggest me to contact recovery files companies in order to recover all my info”. Really?? Anyone can help me? Any suggestion?

Try to read your hard disk with https://www.diskinternals.com/linux-reader/

First open your My Cloud enclosure. Follow this video https://www.youtube.com/watch?v=DKoBWOVmbjA

Then disconnect the circuit board & connect the hard disk with a USB to SATA cable (with 12V adaptor) to your Mac/PC. In Linux Reader you’ll see the biggest partition. Double click & there’s all your data. Right click on the map/file you want to restore & choose ‘Save’.

Thanks for your answer. Im an iMac user, is there any option for this? (try to read the hard disk)

You can try this https://www.paragon-software.com/home/extfs-mac/ You can use the trial version for 10 days.

Thank you, but first I need to open enclosure and connect it with sata-usb cable?

Another thing, adapter for 2.5mm sata or 3.5mm??

Without taking the hard disk out you can only connect through network. If you can still connect via SSH use https://macdownload.informer.com/cyberduck/ to copy the files. Otherwise the only way is with the cable. It’s 3,5 inch SATA hdd.

Sorry, I’m not expert user. I downloaded Cyberduck, but it asks me for old java. I cannot install that old java because it says I have a newer version. I don’t understand what you mean with SSH. I have access only to dashboard on my safari if I put the IP address on it. I saw option for SSH on dashboard and I activated it, gave me user name and password, now what can I do?

I don’t know what am I doing, I pay for Cyberduck on App Store, I was clicking all buttons (as xbox) and suddenly I got this, take a look . Is this mycloud files??? there are a lot of folders inside other folders, where can I find my files??

In shares. Is it the IP address of your My Cloud? If not look in Settings > Network of your My Cloud. Then connect with your root credentials. In my device it’s /DataVolume/shares/ where the maps & files are

Yes, the IP belongs to mycloud (I connect thru this IP to my dashboard)
Please take a look at my options for connections
By the way, what are the root credentials?

Choose SFTP, Login: root, Password: welc0me. Then go to /DataVolume/shares

I did that but I got error message

The port should be 22

Note that for second gen v2.x firmware single bay My Cloud’s the SSH login name is no longer “root”. WD changed it to “sshd”.

How to Access a My Cloud Using SSH (Secure Shell)
https://support-en.wd.com/app/answers/detail/a_id/26497/

Hello, I actually did what you said, change root to sshd and it worked, but I got this screen, I don’t see any \datavolume folder, what is the problem?? any solution?? heeeelp

I don’t have a second gen My Cloud but based on that screen capture try the Shares folder and see if your Shares are listed there (or in a subfolder there). The 2nd gen My Cloud’s apparently use a different folder structure than the 1st gen My Cloud’s.

Actually I checked that and there is no files inside “shares”. Now I have another problem, modem restarted and now I don’t know what IP is my dashboard. On iMac, I type arp -a and I don’t see the Mac address on the list. What can I do? would I have only access if I connect with usb to sata connector?

Hello, im a Mac user, I have a usb to sata, I connected the HDD (after taking the enclosure) and my Mac says “its not possible to read”. Do I need a special program or app?