MyCloud single bay misbehavior

I have an old MyCloud 4 TB single-bay NAS that has started to misbehave. I have tried a 40-second reset, which clears the operating system, but it still misbehaves. Here are the symptoms:

On the home screen, the pie chart shows 1.7 TB as “Free”, and rest as “Other”, even though a large number of the files are actually photos, music, and videos. Content scan shows “idle”, but if I click the right arrow the content scan status shows videos as 1679/1696 99%, Music Tracks as complete, Photos as complete, and “Other” as 34330/36658 94%. I am guessing that the content scan is getting stuck on some video file and some “other” file, and that is also why the pie chart is not showing the correct data.

If I look at the DLNA database under “Settings” → Media, it shows Music Tracks = 8399, Videos = 1610, and Pictures = 24977. I am guessing that those figures are only those media files that are on shares that I have enabled for streaming, which is why the numbers are smaller.

So I guess the content scan that is getting stuck on some corrupt file. Can anyone suggest how to track this down?

What firmware version are you running on your single bay My Cloud?

Sometimes a My Cloud Dashboard > Settings > Utilities > System Only Restore will fix weird issues with the My Cloud. Won’t fix a dying hard drive though.

Note that using special characters in file names may cause issues with the file scanning modules of the My Cloud. Some troubleshooting suggestions. Disable both the DLNA (Twonky) and iTunes via the My Cloud Dashboard > Settings section. If the problem is with the Twonky DLNA media server one may need to access the Twonky administration page (example: http://wdmycloud:9000), assuming OS5 firmware retains the Twonky adminstration page, and clear/delete/reset the Twonky database.

Edit to add: One could, if they still have SSH access to the My Cloud, run the SSH command: sh /usr/local/sbin/ noreformat (then reboot their My Cloud) to try and perform a system only factory reset. Use this command at your own risk however!

Thank you for the ideas. My plan of action is now this:

I have been running a full system diagnostic from the utilities page of the web interface since 09:00 UTC this morning. So far it is at 90%, and no problems found.

If that does not signal anything, I shall try deleting the shares one at a time to see if I can get the content scan to complete, and restore each share from a backup as I go. My reasoning is that if it is due to a filename that is too long, or with odd characters, then I shall see the content scan complete. I will then restore the offending share folder by folder until I find the offending folder, etc.

I’ll post if I find something.

BTW, the firmware is v04.05.00-342. Is was on automatic update, and the last update was 24th September 2019.

There is an option somewhere to rebuild the database/index. . .I think you have done that step?

Note this (OS5 subforum) is really the wrong subforum for any discussion about the first gen single bay My Cloud. The first gen single bay My Cloud is not supported by the OS5 firmware, only the second generation single bay My Cloud units, that ran the OS3 v2.x firmware, is supported by OS5. The first generation single bay My Cloud only supports the v4.x OS3 firmware.

OS3 My Cloud

For anyone using the OS5 firmware be careful of performing certain methods or processes (like the SSH commands) discussed in this thread as those discussion may possibly only apply or affect OS3 firmware single bay My Cloud units.

Yes there are. Might as well delve into several of them for those unfamiliar with them in the OS3 firmware.

Note the following applies to an OS3 single bay My Cloud running v4.x and v2.x firmware. Unknown if OS5 v5.x firmware has the same options or would be affected by various methods/commands discussed below.

There are several “rebuild” database options on a first generation v4.x firmware single bay My Cloud. One is to rebuild the Cloud Access database via the My Cloud Dashboard > Settings > General > Cloud Access > Remote Access > Configure.

On the first generation v4.x firmware single bay My Cloud one can rebuild the Twonky database via the My Cloud Dashboard > Settings > Media > DLNA Media Server > DLNA database > Rebuild, or one can choose Rescan. One can clear the Twonky DLNA media server Cache via the wdmycloud:9000 Twonky administration page (see Advanced > Clear Cache. Or from that same page reset Twonky to default via the Reset to Default button.

Or if one continues to have scanning/indexing issues on a first gen v4.x single bay My Cloud, even after disabling the media servers (Twonky and iTunes), one can see if stopping certain services via SSH solve the issue. Note: Disabling various services may impact certain single bay v4.x or v2.x firmware My Cloud features. Unknown how such methods would affect an OS5 firmware My Cloud. Each of the following commands issued via SSH, in the OS3 firmware, will stop the respective service (as always proceed at your own risk!):

/etc/init.d/restsdk-serverd stop
/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop
/etc/init.d/wdnotifierd stop

One can automate the stopping of these services upon bootup or reboot of their single bay OS3 v4.x or v2.x single bay My Cloud by creating a file called S98user-start in the /etc/rc2.d/ directory via SSH. For more information do a search, in the OS3 My Cloud subforum, for “sleep” and there is much discussion on how to stop certain modules/services and invoke those module shutdown commands at startup/reboot.

Much, more discussion on OS3 v4.x and v2.x single bay My Cloud issues in the dedicated OS3 single bay My Cloud subforum:

Hi, yes I have tried that. I think it rebuilds the DLNA database rather than the content scanning database. The DLNA database seems to be OK … that is, it is streaming music and videos, and I have not come across anything yet that it will not stream. What does seem not to be working properly is the content scan database that populates the pie chart on the home page, for example.

Sorry, I didn’t realize I was on the wrong forum. Which is the correct forum for single-bay MyCloud like my setup?

Uh I included the correct subforum for the OS3 single bay My Cloud it in my reply above. :wink:

Here it is again…

Edit to add: There are a number of past discussions in the dedicated OS3 single bay My Cloud subforum that discuss content scan issues. See this search link:

Sorry about that. I was still a bit confused about how v04.05.00-342 seems to be known as OS3.

Anyway, the problem seems to be fixed now, after I rebuilt the content database. I had not understood that actually the content database is a separate thing from the DLNA media database. And it is the content database that populates the pie chart on the home page.

The DLNA media streamer is also known as “Twonky”, right?

So … now to try and send back that useless MyCloud Home brick.

Thanks once again for your help.