MyCloud shares visible in windows 10 file explorer network list

Continuing the discussion from Windows 10 Network Doesn't See My Cloud:

My original reply didn’t let me type a response.
I have a windows 8.1 and 10 machine running on the same network. The windows 8.1 machine has no network issues since I upgraded the other to windows 10. Mycloud shows in the a storge device on the right of file explorer, a click takes you to the MyCloud web interface, works fine. I have multiple shares maped to the windows 10 machine, works fine. It can’t see the MyCloud in the network. All the WD apps work fine and supply access. The workgruop is correct, the homegroup is on, SMB1 is on, network is private, there are so many updn features in windows 10 that I don’t know if all required on turned on (could use some help as to what is required). I can reboot or power cycle the MyCloud and it shows in network on windows 10 machine until the computer is rebooted, then back to same as above.
Again my Windows 8.1 machine as no issues. I’ve been on the Windows forums as well. This seems to be a problem with more than WD NAS connections. I agree it is a windows 10 issue, can’t rely on MicroSoft to solve it at least not quickly. Looking for successes, they all seem to be from different actions. I’m self taught and SSH etc. is above my level. I’m concerned about causing other issue as I try to solve this with not understand fulling what is involved with each setting.

With Windows 10 there are apparently some problems with how it searches the local network for devices. To that end a couple of things to check that will help Windows 10 find devices on the local network.

First, configure the network connection so your on “Private” network and not a “Public” network. Sometimes when installing or updating Windows 10 it will configure your network connection as a “Public” network.

Second, ensure you have enabled “Network Discovery and File Sharing” on the “Private” network otherwise Windows 10 won’t discover any network devices.

If your network location is set to “Public” then see this link for general directions on how to set the network connection to “Private”.

How to change Windows 10 network location from Public to Private

To enable network discovery and file sharing on the “Private” network do the following.

Open “Manage advanced sharing settings” via the search/Cortana field.
Under the Private section, under Network discovery, enable both:
Turn on network discovery
Turn on automatic setup of network conected devices.

Next, under File and printer sharing, enable:
Turn on file and printer sharing

Under the HomeGroup connections make sure the following setting is enabled:
allow Windows to manage homegroup connections (recommended)

Go back and check Windows File Explorer’s Network section and the WD My Cloud should be listed in the “Computer” section.

I double checked these basic settings, all good: same problem.

Same problem here. It`s a bug in Windows 10. A lot of people talking about that in foruns. Windows 10 do not see network shares (the problem is not only with WD Drives). I had to downgrade to Windows :disappointed:-(

See the tacked first thread of this subforum (link below). It lists several methods used by others to fix their Windows 10 / My Cloud issues. In my case it was changing the SMB setting on one Windows 10 PC solved the problem.

1 Like

Yesterday I noticed that the my Cloud devices were not listed under the computer in windows explorer. In fact the only thing listed under network was the laptop computer that I was running windows explorer on. So I clicked the refresh button and everything reappeared.

I’m running windows 10 latest upgrade.


I have a network with 4 notebooks, 3 android mobiles, 2 WD external ethernet hard drive, 1 WDRV Live. After upgrade to Windows 10, when I click to “Network” (On Windows Explorer left panel), I can not see nothing. The computer can not see even itself. I have been searching in foruns and a lot of people are talking about this Windows 10 bug. I have tryed to configure the network using the router (DLink dir635) and the modem Humax. Nothing. The curious is: I have 3 notebooks with Windows 10. If I turn them all off and turn off the router, after turn on again, the first computer the see the shares, but the others can not. Other people talk in foruns about this problem. My problem is not only makes Windows 10 see My Cloud and My Book Live, but get back my home network Windows 10 get way :-(disappointed:

Hopefully for those having problems the solution of hitting the refresh button (which is mentioned in Windows 10 Specific Method 4 in the Compilation of Windows 10 Methods, Steps and Solutions thread) will work for them. In my case it worked prior to the November update, post November update it no longer works to show the My Cloud on the one Win 10 PC with the My Cloud problems. :frowning:

1 Like

In the beginning, I thought the problem was with the Windows 10 version. I have one notebook Windows 10 (10240) that work perfectly well and two notebooks with Windows 10 (1511) that did not. After, I discover that, as I do not turn them off, the diference was not the Windows 10 version, but the fact the notebook with Windows 10 (10240) was the first turned on in the network. As I explained before, when I turn them all off, if I turn one notebook with Windows 10 (1511) [November Update] it will work perfectly well, but only the first turned on.

My issue seems to have been the SMB & SMB3 settings in windows. I disabled it and enabled smb1 on windows10 (followed proceedure oulined in Compilation of Windows 10 Methods, Steps and Solutions) from Bennor post.