MyCloud share name case

I changed the share name of a USB drive connected to my MyCloud to “TV” in upper case, but it displays in Windows 7 Explorer as “tv” in lower case. If I ssh into the MyCloud and look in “/shares” with “ls -al” it shows as “TV -> /var/media/TV”, which I assume is a link.

Is this a problem with Windows, and is there anything I can do to correct it?

I have v04.00.00-607 firmware on my MyCloud

Hello,

It would seem like it has to do more with windows than the unit itself, If you check on the My Cloud app does the share show in upper case?

Windows does muck about with folder name case. It seems to have a ‘long memory’, and refuse to comply with folder name changes that are just case changes.

You know its funny I noticed this last night when moving files around and created a Share called “TV” on the My Cloud using the Dashboard interface. The Dashboard shows the characters as upper case, yet windows shows it as lower case. At first I was wondering why then chalked it up to Windows being Windows. LOL.

The other thing I noticed is that the Dashboard interface limits the types of characters one can use for a Share name, they apparently confine it to numbers and letters rather than allowing characters like “!”, "~"and the like. The use of special characters help with pushing a folder to the top of a list rather than being farther down when viewed alphabetically/numerically. The use of special characters helps especially with media players and having one particular folder at the top of the list when one has a large number of folders, like for TV series.

The Android app doesn’t show any shares or folders, in fact, it doesn’t seem to show any content from the device! All I see is this:

Pressing on the various icons does nothing.

If I view the MyCloud with the file manager on my Android tablet, it shows the share name as “TV” in upper case.

My two android devices show the word “TV” upper cased both in the WD My Cloud app and the ES File Explorer app.

The icons on the right side in the screen capture below don’t actually do anything (on my tablet). Instead its the Photos, Music, Videos icons above the folder list below that are select-able when in a folder with media content.

Windows Explorer:

I uninstalled the app, then re-installed. After going through the login setup, it took me to a screen that said there was a firmware update available. At the bottom of the screen was a button that said “Update Firmware”, and under that was the word “Skip”, directly on top of the “Home” button. I tried to press “Skip”, but it went to my tablet’s home screen. I went back to the MyCloud app and tried pressing “Skip” again, was again sent to my homescreen, and tried again and again a bunch of times in quick succession before giving up.

I then tried to access the MyCloud from my Windows machine and got an error saying the network path didn’t exist! While trying to straighten that out, I got an email from the MyCloud saying that a firmware update had begun! After a few minutes of terror, fearing that it would brick, it finally came back online with the new firmware and seems to be OK. The Android app can now see the shares, and the share name shows as “TV” as it should. However, Windows Explorer still shows it as “tv”.

I opened an ssh shell using PuTTY, and the history showed some apt-get commands that I never entered, which I presume has something to do with the firmware upgrade. Unfortunately, all of my bash history is gone, including some command lines I had figured out to do various tasks, which I will now have to figure out again!

I found the solution here: http://windowsitpro.com/systems-management/how-can-i-stop-windows-explorer-changing-case-my-filenames

It involves editing the Windows registry.

Nice find. That fixed it (at least on my end) in Explorer by changing DontPrettyPath from 0 to 1 then reboot the PC.