Mycloud remote access down

I have not been able to access files for two days. I am able to log in to mycloud when I’m at my home computer, where my device is located, but not elsewhere.

Reboot only your NAS. This can likely fix things. Let me know. if it does and i will fill in the details

Will do

@willcka I have been using for the last couple of days without a problem. I had files I had saved on my laptop that I wanted to upload to my My Cloud since I am away from home.

1 Like

I’m back in business with remote access this morning. That seemed to do the trick. Thanks!

Glad my suggestion solved the issue.
What caused the problem: the router rebooted either purposely or accidentally. When this happens the NAS loses the port forwarding IP address for remote access and it needs a reboot. It then gets the correct IP and works again. Do this reboot any time you lose remote access.

Please mark this post solved so it can help others. Thanks.

By reboot you mean going to the router’s dashboard, then clicking the top right person-symbol and then clicking reboot?

Reboot router means turning off router followed by turning router back on.