Mycloud Red light

I have a red light on my mycloud box. I tried resetting using the reset button at the back, turning the power on and off, Disconnecting from the router etc but nothing seems to work. Any ideas.

Woke up this morning to my mycloud doing the same thing? red light, can’t access drive in my network in windows explorer, I can get to device homepage, diagnostics coming up with a caution flag? worried…

as I am browsing the forums, the caution flag on the device homepage has just changed to red, critical, with the pop up box saying content status not mounted. also homepage says capacity 0kb free. it is a 2tb model, and I have over a tb of data on it…

Red lights are normally indicative of drive problems, so time to back-up all your critical or non-replacable data to somewhere else, if possible and not already done.

thank you darrenhill, I have had zero problems with this drive in the two years I have owned it, I have not backed up this data, (I know my own fault) is there any way to get to the files on the drive while it is in this state?

Difficult to say, it depends exactly what the issue may be.

I’d get in touch with WD support and see what they can recommend, as they’re the experts in this kind of thing. I guess from your comment that the drive may be out of warranty, but it could be worth talking to them anyway.

Depending on what the data is, there are companies out there who may offer data recovery services, but they can be pricey to use. There is also software you can install to try, but that’s more normal for internal drives and may well not work for an external drive like a MyCloud.

I am hoping good things here?? i am browsing the forums, will the restore without losing data function work?? i know my options are limited… im running windows 8.1 i see other threads about this, any suggestion??

Personally I would doubt it, but it may not hurt to try. It sounds more like a hardware failure rather than a corruption or problem with the device firmware (which is more what the reset is for).

As I said I’d contact WD support and get them to assist you, but it may be beyond their capability too.

i had the same problem for a few hours, and feared the worse. But then it just went away… and the blue light came back. fingers crossed it does the same for you.

Well, you were right, I shut down the my cloud yesterday after doing a system only restore, and powered it back up this morning, and it is a blue light. I understand with a system only restore, all my data should be intact?? my dashboard says scanning under content scan, but I cant see anything in windows explorer. I truly hope somehow my data is still there.

Yes, system-only restore shouldn’t touch your data, it just resets the firmware.

However in all cases, if you’ve had red lights indicating drive issues, make sure that any and all critical, non-replaceable or otherwise required data is backed up as it may well still indicate that there is a (perhaps intermittent) hardware issue which could come back at any time.

In the best case take it as a reminder and warning about the necessity of data backup…

Thank you, and yes I will get this data off this drive, once I am able to access it? I understand all shares go to public shares and I have to recreate everything? how long until I am able to see my data in windows explorer? dashboard still says 0kb free content scan says scanning

Last time I did it (on my MyCloud Mirror rather than a MyCloud) all that it did from a user-side viewpoint was reset the admin user credentials (back to admin/no password) and my networking from static back to DHCP.

The shares weren’t touched at all, although I have also seen documentation that you refer to which says they should all be set to public. In my case the private ones stayed exactly as they were.

What you’re reporting though would still make me think that your drive has failed, and the unit just hasn’t realised it yet. As I said before, I would get in touch with WD Support on this one as all the read-outs are indicating that the firmware can’t read the drive properly regardless of what colour the LEDs are illuminating at the moment.

thank you. I had six shares created (seven if you count public) and they are not showing up. I just recreated one share, same name as before, and created my username again, nothing is showing up. I am nervous as after an hour dashboard still says 0kb free, not the normal graph with how much space used/unused. guess I will contact them, praying my data is still here somewhere…

I wouldn’t try recreating share names from the Dashboard; that might destroy any existing files.

I would log in to the linux command line via SSH,

and see what the file system looks like there:

cd /shares

If you can’t see your shares there, then I suspect something unpleasant has happened.

ok, well I hope doing it didn’t do any damage. I am running windows, I just logged in via putty, typed the commands as you said too, and it comes up no such file or directory… so unpleasant??

Unfortunately it looks unpleasant yes.

Given what you’ve reported, I think the damage was already done before you tried recreating the shares, so you probably didn’t make it any worse.

If it’s vital or critical unreplacable data then you may be looking at a data recovery service scenario (see here for WD’s partners on that), but it can be a costly exercise. If not then one to chalk up to experience (and learning about backing up the hard way), RMA if applicable and carry on.

Well, something is obviously running, so the disk isn’t completely dead…

My commands should have got you to the user share area.

You can go to the top of the file system, and have a look to see what’s there:

cd /

or just

ls /

You ought to see a couple of directories:


/DataVolume is the top level of user data
/CacheVolume is the top level of user hmmm… app data, e.g. used for Twonky’s config file and database.

/DataVolume/shares ought to have your user shares, and the /shares should be a shortcut to this directory.

If these are missing, then something very unpleasant has happened.

I’m there now. Just two folders in /Data volume. backup and cache…that’s
it. I just can’t understand where my shares went… Thank for your help.