Mycloud partition is not recognised after power loss. trying to unbrick the disk

Hello.
I have a mycloud device 4TB. Recently I had a power loss and I lost contact with the 4TB partition. The capacity in dashboard dropped to 1.8 Gb. I have no experience how this works so I started searching on sites. After the power loss I thought the disk was damaged, but this didn’t happen.
I understood that the disk is shipped with an operating system. I did ssh, I logged in as root I tried to understand what happened. I figured out that this is a linux system so I tried to do a diagnostic of the problem. I used parted -l command and I saw the partitions.


I don’t know if the image is uploaded, so I copy the output

Disk /dev/sda: 4001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number Start End Size File system Name Flags
3 15.7MB 528MB 513MB linux-swap(v1) primary
1 528MB 2576MB 2048MB ext3 primary raid
2 2576MB 4624MB 2048MB ext3 primary raid
5 4624MB 4724MB 99.6MB primary
6 4724MB 4824MB 101MB primary
7 4824MB 4826MB 1049kB primary
8 4826MB 4828MB 2097kB primary
4 4828MB 4001GB 3996GB primary

Model: Linux Software RAID Array (md)
Disk /dev/md1: 2048MB
Sector size (logical/physical): 512B/4096B
Partition Table: loop

Number Start End Size File system Flags
1 0.00B 2048MB 2048MB ext3

WDMyCloud:~#

My 4TB are there with contents that I don’t care to lose. (They are backed up before the power loss). My problem is that the 4TB partition does not have an “ext3” filesystem or so. I cannot mount it, I get errors like wrong system (I tried ext2, ext3 and ext4) and I got errors like bad blocks.

WDMyCloud:~# mount -t ext2 /dev/sda4 /mnt
mount: wrong fs type, bad option, bad superblock on /dev/sda4,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

I did mke2fs -n /dev/sda4 and I obtained the number of blocks.
For each one of them I typed the command
e2fsck -b NUMBER /dev/sda4
It says that some journals are wrong and I started fixing them. However it says that **ext3 journal has been deleted. - filesystem is now ext2 only **.
then
/dev/sda4 contains a file system with errors, check forced.
and It looks to correct the errors.
It is a long period process as the number of blocks is more than 10.
Occasionally I do reboots but still when I use parted -l I don’t see any filesystem.

Do you know if there a way to make it work again? Fix and mount the 4TB partition? What tools should I use ?
Any help will be greatly appreciated.
Thanks for your time.

You could refer to the following link: https://support-en.wd.com/app/answers/detail/a_id/7750