MyCloud overtake of main router IP after FW update/UPnP Enabled

I purchsed this a few days ago. I installed the firmware update and believe it overtook my router’s main IP. Meaning, I tried to go to my router’s main IP and I am brought to the MyCloud dashboard. I had aso enabled UPnP, beforehand. Now the question. I am at 90 percent of a factory restore in the attempt to restore the main router IP back to normal as a MyCloud FW update should not overtake a router IP (just my opinion). Will the factory restore achieve returning the router IP back to normal or would it be advisable to reinstall the router?

Thank you.

If your router is handing out device IP’s and the configuration of you WDMyCloud Network service remains unchaged, that is it’s still set to receive its IP via DHCP, then what you describe isn’t possible. If you haven’t made any changes to the way your WDMyCloud obtains it’s IP address then turning then rebooting it may correct the problem. I’d also try flushing your browsers cache.

The IPs are handed out DHCP. I updated the FW from the dashboard and enabled UPnP. Result, the main router IP is now the MyCloud IP. Also, the MyCloud IP (different) also leads to the dashboard. It’s possible. It happened.

A reboot of the MyCloud was done, no effect. Cleared browser cache, no effect.


The factory restore did not fix the router IP/return it to normal. I must try re-installing the router, but after all MyCloud FW is up to date.

I really don’t know much about networks but  have you tried to unplug the MyCloud from your router, reset the router and see if the IP for router returns to the default one. Just a suggestion.