Mycloud OS5 android opening WORD and Excel files

Who can help me?
We have a MYCloud ex2Ultra. It works fine on PC and laptop. Mycloud OS5 installed on Android device to read files stored on MYCloudex2Ultra. However some doc, docx, xlsx won’t open and some can be opened…

Wie kan mij helpen?
Wij hebben een MYCloud ex2Ultra. Via de pc en laptop werkt het prima. Mycloud OS5 geïnstalleerd op Android toestel om bestanden te kunnen lezen die zijn opgeslagen op de MYCloudex2Ultra. Echter sommige doc, docx, xlsx worden niet geopend en sommige kunnen wel geopend worden…

Hi @Margreet,

Please be informed that maybe the files are corrupted so you are unable to open the few files.

Please refer to the article Alternate 3rd Party Apps and Programs:
https://support-en.wd.com/app/answers/detail/a_id/2677

If further assistance is needed, please open a case with our support team at the following:
https://support-en.wd.com/app/askweb

@Keerti_01
thanks for your reply (sorry for my late response, but i didn’t receive a notification).
Both the mobile version of Excel and Word are installed on my mobile.
The files are not damaged, they can be opened via PC and laptop, so just not via mobile/My Cloud OS 5. (previously with OS 3 it was no problem)

Is there nobody who can help me???
Or it’s a bug of OS5?

Hi @Margreet,

For a hard drive to be able to be read from and written to on both a Windows, macOS computer and android devices it must be formatted to ExFAT file format.

Please refer to the below link How to Format a Drive for Use on Windows and macOS (exFat or FAT32):
https://support-en.wd.com/app/answers/detail/a_id/20821

Hi @keerti-01, thanks for your response. But we have been using our hardware MycloudEx2uktra for years. Until January also with mobile via OS3. After the update to OS5, we can no longer read some word files and some excel files on mobile. Very strange, that does not apply to all files. That’s why I wonder if it’s the MycloudEx2ultra.

What happens if you download those files on the mobile device and then try to open them using the Microsoft app on the mobile device? In other words download the file using the OS5 mobile app but open them outside of the OS5 mobile app.

Thanks for your reply.

when I open OS5 app and I want to open an excel file (one that I know won’t work) then I get the following image (see billiard 1). Appendix 2 for a word file. I can’t download it either (which I find a bit cumbersome, especially if the file is very large and you just want to look at it).

When I first open the Word app on the mobile and I want to find the file, I can’t get into MyCloudEx2Ultra. If I want to add a location here, I don’t see it in the list either. (see appendix 3-6)

Btw, sorry for my English, it’s not my native language.

Wkr,

Margreet

image001.jpg

WTS technical supply

Horst 18

8266 JJ Kampen

The Netherlands

Tel.: +31 (0)38 3312663

E-mail: wts@draaiwerk.nl

Web: www.draaiwerk.nl

KvK Zwolle: 05053227

Is there nobody who can help me??? :face_with_spiral_eyes:

There is some information in the following WD Knowledge Base Article on how to save files using their OS5 mobile app:

My Cloud OS 5: Manage Files on Web and Mobile App
https://support-en.wd.com/app/answers/detail/a_id/29969

Does that mean that I first have to add an extra folder in my Public and then drag documents to this folder via the PC to be able to read them on my mobile?
Seems a bit cumbersome to me.
And opening the file via Word or Excel on my mobile is not yet available.
I want only to read (not even edit or something else) documents who are stored in MyCloudEx2Ultra.

It says Choose a share and they use the Public share as an example. Chose what ever share the file is in that you want to download to your mobile device. Once saved on your mobile device you would then open the file and the mobile device should use what ever app is appropriate (if installed on the mobile device).

If one choose Open In rather than Save to mobile device within the app the mobile device should try to use an appropriate app to open the file. If no appropriate app is installed one may need to install the appropriate app on their mobile device.

Yes, i understand. It was also for me an example. But before using OS5 we had OS3 en we hadn’t any problems to read documents who are stored in MyCloudEx2Utra. With OS5 some documents i can’t open or save on my mobile and others no problem …
I chose Open In but the app can’t find Word or Excel. Both Word as Excel are installed on my mobile. And with some other documents (also .doc or .docx or .xls or .xlsx) there are no problems to read … :worried:

As a troubleshooting step; have you tried renaming the problematic files to a file different name and then testing to see if they can be opened on the mobile device? Could be the file name containing special characters or incorrect file extension (or being open by another user) is preventing the mobile device from opening the file. Or using a device that can open the files, save the file to the local computer, remove the files from the My Cloud, then open the file on the local computer and save a new version of that file to the My Cloud and see if the mobile device can access the file.

Make sure you have installed the latest My Cloud app for OS 5 (not the one for others), should be v 4.4.29 (2021-12-21) or newer. This could also be a bug in the Android app for My Cloud OS 5.

To check if your the file manager is working in Android, try installing File Manager Plus or Solid Explorer for Android, both have free versions and they should be able to read the LAN samba share from the My Cloud OS 5 and these file managers will ask you to open the file (in MS Office for Android) for example. If these file managers work and the MC OS 5 Android doesn’t, then it is probably a bug or deprecated features.

There are ways to use the two aforementioned Android managers from the internet to securely access the files in your local LAN for free, but you have to install the free Tailscale VPN on both the mobile and the NAS or have a Tailscale subnet router in the same subnet as the NAS.

If your NAS is more than a few years old and you are using it commercially in a business as you seem to be doing, you should really think about shopping for a new NAS or another brand of NAS that is more capable and reliable.

edited: looks like a deprecated feature as noted

The above is not clear language for me. :pensive:
My MyCloud has version 4.21 and MyCloud OS 5 on my mobile has version 4.19
I can open the files via the web (must download them first, which was not necessary with OS 3 and which I am definitely not happy with.)
I downloaded File Manager Plus but can’t find MyCloudEx2Ultra on it. So we won’t go any further with that.
Buying a new NAS now doesn’t feel right. Everything works properly only since OS5 the connection with the mobile does not work well with all files.

According to the above thread ‘File manager not in app’, the WebFile Viewer is deprecated in OS 5 which means it is no longer supported.

File manager plus is actually one of the most capable free file manager around. If a share is on a LAN, it will be able to connect to it. You will need to add remote share and then choose local - if your WD samba is working, it will show up on the mobile app.