MyCloud only appear in Window 10 Network Computer one at a time


#1

Hi
I have a WD My Cloud 4TB, 2 laptops and one desktop running window 10 at the moment in my home network.
All the window devices can see My Cloud under “Media Devices” and “Storage” in Network all the time. All can access My Cloud via the web page.

However, only one of the window device at a time can see My Cloud under “Computer” in Network at any one time but not all 3 window devices can at the same time.

Only when switch off the window device that seeing My Cloud under “Computer” in Network, then one of the other can see My Cloud under “Computer” in Network and so on. Even power back on that previously can see My Cloud, still only one Window device can see My Cloud in “Computer” under Network.

Is there anyway to have all three Window devices to see My Cloud in “Computer” under Network all the time??

Thanks!!!

Regards

Kevin


#2

Mine is showing up on both my Desktop and Laptop, running Windows 10 with all updates, under Computer.

Are all your devices in the same workgroup and is Network discovery on?
Have you tried a reboot of your router?
Have you created a Home group and do you have all your computers in it.


#3

Hi cat0W

Thanks for your reply.

All my Window 10 devices are in the same workgroup and can see each others in the same time

My issue with MyCloud is only one Window 10 PC/laptop can see it at any one time under “Computer”. The other two cannot. If I switched off the one that has Mycloud under “Computer”, then only one of the other PC/laptop will then have MyCloud under Computer. Even if I switch back on the original PC/laptop, it will not show back MuCloud under Computer any more, unless I switch off the one having MyCloud under its Computer.

However, all three PC/laptops can see MyCloude under Storage and Media Devices all at the same time.

Router has been rebooted many times, but still the same.

Regards

Kevin


#4

If you haven’t seen it already you may want to review the following post and check your Windows 10 PC for the settings described in Windows 10 Specific Methods 1 through 5.

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576


#5

Hi Bennor

Thanks for your reply.

My issue is not that my PC/laptop cannot see MyCloud at all. This issue is if one of them have MyCloud under Computer, the others won’t. Another word only one of my PC/laptop can see MyCloud at any one time and usually is the first one that tries to detect the Network will get MyCloud under Computer.

I would like to have all of my PC/laptops to have MyCloud under Computer all the time when they are on.

Regards

Kevin


#6

You might (and I stress ‘might’) be having an issue with individual computers on your network being elected as the Master Browser. If so you want to be sure that only a non-computer, such as your gateway router, is the permanent Master Browser.

Check this article to see if that is the case:

Paul


#7

See the link I posted earlier and ensure all computers are using the same settings. And as the previous poster indicated check to see which device is electing itself master browser. Also make sure (if you haven’t already) to either assign the My Cloud a static IP address or configure the My Cloud Dashboard > Settings > Network for a static IP address.


#8

Hi

Thanks both for your suggestion.

After assigning a static IP address to MyCloud , turning “Local Master Browser” on in MyCloud and rebooted it, now all my computer/lapstop have MyCloud under Computer.

Regards

Kevin